summaryrefslogtreecommitdiff
path: root/python-fabric2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-fabric2.spec')
-rw-r--r--python-fabric2.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-fabric2.spec b/python-fabric2.spec
new file mode 100644
index 0000000..3153029
--- /dev/null
+++ b/python-fabric2.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-fabric2
+Version: 3.0.0
+Release: 1
+Summary: High level SSH command execution
+License: BSD
+URL: https://fabfile.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/39/ec/865aa4a92d5982361c07b0caff913ee3f398b40158870fd76c57d42ec212/fabric2-3.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-invoke
+Requires: python3-paramiko
+Requires: python3-pytest
+
+%description
+Fabric is a high level Python (2.7, 3.4+) library designed to execute shell
+commands remotely over SSH, yielding useful Python objects in return. It builds
+on top of `Invoke <https://pyinvoke.org>`_ (subprocess command execution and
+command-line features) and `Paramiko <https://paramiko.org>`_ (SSH protocol
+implementation), extending their APIs to complement one another and provide
+additional functionality.
+To find out what's new in this version of Fabric, please see `the changelog
+<https://fabfile.org/changelog.html#{}>`_.
+The project maintainer keeps a `roadmap
+<https://bitprophet.org/projects#roadmap>`_ on his website.
+
+%package -n python3-fabric2
+Summary: High level SSH command execution
+Provides: python-fabric2
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-fabric2
+Fabric is a high level Python (2.7, 3.4+) library designed to execute shell
+commands remotely over SSH, yielding useful Python objects in return. It builds
+on top of `Invoke <https://pyinvoke.org>`_ (subprocess command execution and
+command-line features) and `Paramiko <https://paramiko.org>`_ (SSH protocol
+implementation), extending their APIs to complement one another and provide
+additional functionality.
+To find out what's new in this version of Fabric, please see `the changelog
+<https://fabfile.org/changelog.html#{}>`_.
+The project maintainer keeps a `roadmap
+<https://bitprophet.org/projects#roadmap>`_ on his website.
+
+%package help
+Summary: Development documents and examples for fabric2
+Provides: python3-fabric2-doc
+%description help
+Fabric is a high level Python (2.7, 3.4+) library designed to execute shell
+commands remotely over SSH, yielding useful Python objects in return. It builds
+on top of `Invoke <https://pyinvoke.org>`_ (subprocess command execution and
+command-line features) and `Paramiko <https://paramiko.org>`_ (SSH protocol
+implementation), extending their APIs to complement one another and provide
+additional functionality.
+To find out what's new in this version of Fabric, please see `the changelog
+<https://fabfile.org/changelog.html#{}>`_.
+The project maintainer keeps a `roadmap
+<https://bitprophet.org/projects#roadmap>`_ on his website.
+
+%prep
+%autosetup -n fabric2-3.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-fabric2 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
+- Package Spec generated