summaryrefslogtreecommitdiff
path: root/python-finta.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-finta.spec')
-rw-r--r--python-finta.spec101
1 files changed, 101 insertions, 0 deletions
diff --git a/python-finta.spec b/python-finta.spec
new file mode 100644
index 0000000..efdaada
--- /dev/null
+++ b/python-finta.spec
@@ -0,0 +1,101 @@
+%global _empty_manifest_terminate_build 0
+Name: python-finta
+Version: 1.3
+Release: 1
+Summary: Common financial technical indicators implemented in Pandas.
+License: LGPLv3+
+URL: https://github.com/peerchemist/finta
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/98/76/b3051112722b50b1900e16eb5784714cd96b19d26b0518a0375036458bcb/finta-1.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-pandas
+
+%description
+I welcome pull requests with new indicators or fixes for existing ones.
+Please submit only indicators that belong in public domain and are
+royalty free.
+## Contributing
+1. Fork it (https://github.com/peerchemist/finta/fork)
+2. Study how it's implemented.
+3. Create your feature branch (`git checkout -b my-new-feature`).
+4. Run [black](https://github.com/ambv/black) code formatter on the finta.py to ensure uniform code style.
+5. Commit your changes (`git commit -am 'Add some feature'`).
+6. Push to the branch (`git push origin my-new-feature`).
+
+%package -n python3-finta
+Summary: Common financial technical indicators implemented in Pandas.
+Provides: python-finta
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-finta
+I welcome pull requests with new indicators or fixes for existing ones.
+Please submit only indicators that belong in public domain and are
+royalty free.
+## Contributing
+1. Fork it (https://github.com/peerchemist/finta/fork)
+2. Study how it's implemented.
+3. Create your feature branch (`git checkout -b my-new-feature`).
+4. Run [black](https://github.com/ambv/black) code formatter on the finta.py to ensure uniform code style.
+5. Commit your changes (`git commit -am 'Add some feature'`).
+6. Push to the branch (`git push origin my-new-feature`).
+
+%package help
+Summary: Development documents and examples for finta
+Provides: python3-finta-doc
+%description help
+I welcome pull requests with new indicators or fixes for existing ones.
+Please submit only indicators that belong in public domain and are
+royalty free.
+## Contributing
+1. Fork it (https://github.com/peerchemist/finta/fork)
+2. Study how it's implemented.
+3. Create your feature branch (`git checkout -b my-new-feature`).
+4. Run [black](https://github.com/ambv/black) code formatter on the finta.py to ensure uniform code style.
+5. Commit your changes (`git commit -am 'Add some feature'`).
+6. Push to the branch (`git push origin my-new-feature`).
+
+%prep
+%autosetup -n finta-1.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-finta -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3-1
+- Package Spec generated