summaryrefslogtreecommitdiff
path: root/python-flake8-import-single.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flake8-import-single.spec')
-rw-r--r--python-flake8-import-single.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-flake8-import-single.spec b/python-flake8-import-single.spec
new file mode 100644
index 0000000..445614a
--- /dev/null
+++ b/python-flake8-import-single.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-flake8-import-single
+Version: 0.1.5
+Release: 1
+Summary: Flake8 plugin that requires single line imports
+License: MIT
+URL: https://github.com/awiddersheim/flake8-import-single
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a3/fb/457b9178d0550de0e5d0c6ca63aec2efb960dcbf136e2be5af7ed23c1d0a/flake8-import-single-0.1.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-flake8
+Requires: python3-flake8
+Requires: python3-flake8-bandit
+Requires: python3-flake8-commas
+Requires: python3-flake8-import-order
+Requires: python3-flake8-print
+Requires: python3-flake8-quotes
+Requires: python3-pytest
+Requires: python3-pytest-cov
+
+%description
+A Flake8 plugin that requires single line imports.
+|Status| |PackageVersion| |PythonVersions|
+
+%package -n python3-flake8-import-single
+Summary: Flake8 plugin that requires single line imports
+Provides: python-flake8-import-single
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-flake8-import-single
+A Flake8 plugin that requires single line imports.
+|Status| |PackageVersion| |PythonVersions|
+
+%package help
+Summary: Development documents and examples for flake8-import-single
+Provides: python3-flake8-import-single-doc
+%description help
+A Flake8 plugin that requires single line imports.
+|Status| |PackageVersion| |PythonVersions|
+
+%prep
+%autosetup -n flake8-import-single-0.1.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-flake8-import-single -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.5-1
+- Package Spec generated