summaryrefslogtreecommitdiff
path: root/python-flake8-variables-names.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flake8-variables-names.spec')
-rw-r--r--python-flake8-variables-names.spec285
1 files changed, 285 insertions, 0 deletions
diff --git a/python-flake8-variables-names.spec b/python-flake8-variables-names.spec
new file mode 100644
index 0000000..1a8eb68
--- /dev/null
+++ b/python-flake8-variables-names.spec
@@ -0,0 +1,285 @@
+%global _empty_manifest_terminate_build 0
+Name: python-flake8-variables-names
+Version: 0.0.5
+Release: 1
+Summary: A flake8 extension that helps to make more readable variables names
+License: MIT
+URL: https://github.com/best-doctor/flake8-variables-names
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/80/a0/6c0a2fc99440a758b06a5c2b4af3931d521b9d2afba940e7a7adc8db9a47/flake8_variables_names-0.0.5.tar.gz
+BuildArch: noarch
+
+
+%description
+# flake8-variables-names
+
+[![Build Status](https://github.com/best-doctor/flake8-variables-names/actions/workflows/build.yml/badge.svg?branch=master)](https://github.com/best-doctor/flake8-variables-names/actions/workflows/build.yml)
+[![Maintainability](https://api.codeclimate.com/v1/badges/c7502e578af3f4437179/maintainability)](https://codeclimate.com/github/best-doctor/flake8-variables-names/maintainability)
+[![Test Coverage](https://api.codeclimate.com/v1/badges/c7502e578af3f4437179/test_coverage)](https://codeclimate.com/github/best-doctor/flake8-variables-names/test_coverage)
+[![PyPI version](https://badge.fury.io/py/flake8-variables-names.svg)](https://badge.fury.io/py/flake8-variables-names)
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/flake8-variables-names)
+
+An extension for flake8 that helps to make more readable variables names.
+
+We believe, that variable name should unmistakably shows, what it contains.
+Thats why we try not to use varnames with only one symbol or not to use
+too common names, such as `result`, `value` or `info`.
+
+This extensions helps to detect such names. By default it works in
+non-strict mode. You can change it with `--use-varnames-strict-mode`
+parameter end extend variable names blacklist even more.
+
+## Installation
+
+```terminal
+pip install flake8-variables-names
+```
+
+## Example
+
+Sample file:
+
+```python
+# test.py
+
+a = 1
+foo = 2
+result = a + foo
+```
+
+Usage:
+
+```terminal
+$ flake8 test.py
+test.py:1:1: VNE001 single letter variable names are not allowed
+test.py:2:1: VNE002 variable name should be clarified
+```
+
+## Error codes
+
+| Error code | Description |
+|:----------:|:-------------------------------------------------------:|
+| VNE001 | single letter variable names like 'XXX' are not allowed |
+| VNE002 | variable name 'XXX' should be clarified |
+| VNE003 | variable names that shadow builtins are not allowed |
+
+## Contributing
+
+We would love you to contribute to our project. It's simple:
+
+- Create an issue with bug you found or proposal you have.
+ Wait for approve from maintainer.
+- Create a pull request. Make sure all checks are green.
+- Fix review comments if any.
+- Be awesome.
+
+Here are useful tips:
+
+- You can run all checks and tests with `make check`.
+ Please do it before CI does.
+- We use [BestDoctor python styleguide](https://github.com/best-doctor/guides/blob/master/guides/en/python_styleguide.md).
+- We respect [Django CoC](https://www.djangoproject.com/conduct/).
+ Make soft, not bullshit.
+
+
+
+
+%package -n python3-flake8-variables-names
+Summary: A flake8 extension that helps to make more readable variables names
+Provides: python-flake8-variables-names
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-flake8-variables-names
+# flake8-variables-names
+
+[![Build Status](https://github.com/best-doctor/flake8-variables-names/actions/workflows/build.yml/badge.svg?branch=master)](https://github.com/best-doctor/flake8-variables-names/actions/workflows/build.yml)
+[![Maintainability](https://api.codeclimate.com/v1/badges/c7502e578af3f4437179/maintainability)](https://codeclimate.com/github/best-doctor/flake8-variables-names/maintainability)
+[![Test Coverage](https://api.codeclimate.com/v1/badges/c7502e578af3f4437179/test_coverage)](https://codeclimate.com/github/best-doctor/flake8-variables-names/test_coverage)
+[![PyPI version](https://badge.fury.io/py/flake8-variables-names.svg)](https://badge.fury.io/py/flake8-variables-names)
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/flake8-variables-names)
+
+An extension for flake8 that helps to make more readable variables names.
+
+We believe, that variable name should unmistakably shows, what it contains.
+Thats why we try not to use varnames with only one symbol or not to use
+too common names, such as `result`, `value` or `info`.
+
+This extensions helps to detect such names. By default it works in
+non-strict mode. You can change it with `--use-varnames-strict-mode`
+parameter end extend variable names blacklist even more.
+
+## Installation
+
+```terminal
+pip install flake8-variables-names
+```
+
+## Example
+
+Sample file:
+
+```python
+# test.py
+
+a = 1
+foo = 2
+result = a + foo
+```
+
+Usage:
+
+```terminal
+$ flake8 test.py
+test.py:1:1: VNE001 single letter variable names are not allowed
+test.py:2:1: VNE002 variable name should be clarified
+```
+
+## Error codes
+
+| Error code | Description |
+|:----------:|:-------------------------------------------------------:|
+| VNE001 | single letter variable names like 'XXX' are not allowed |
+| VNE002 | variable name 'XXX' should be clarified |
+| VNE003 | variable names that shadow builtins are not allowed |
+
+## Contributing
+
+We would love you to contribute to our project. It's simple:
+
+- Create an issue with bug you found or proposal you have.
+ Wait for approve from maintainer.
+- Create a pull request. Make sure all checks are green.
+- Fix review comments if any.
+- Be awesome.
+
+Here are useful tips:
+
+- You can run all checks and tests with `make check`.
+ Please do it before CI does.
+- We use [BestDoctor python styleguide](https://github.com/best-doctor/guides/blob/master/guides/en/python_styleguide.md).
+- We respect [Django CoC](https://www.djangoproject.com/conduct/).
+ Make soft, not bullshit.
+
+
+
+
+%package help
+Summary: Development documents and examples for flake8-variables-names
+Provides: python3-flake8-variables-names-doc
+%description help
+# flake8-variables-names
+
+[![Build Status](https://github.com/best-doctor/flake8-variables-names/actions/workflows/build.yml/badge.svg?branch=master)](https://github.com/best-doctor/flake8-variables-names/actions/workflows/build.yml)
+[![Maintainability](https://api.codeclimate.com/v1/badges/c7502e578af3f4437179/maintainability)](https://codeclimate.com/github/best-doctor/flake8-variables-names/maintainability)
+[![Test Coverage](https://api.codeclimate.com/v1/badges/c7502e578af3f4437179/test_coverage)](https://codeclimate.com/github/best-doctor/flake8-variables-names/test_coverage)
+[![PyPI version](https://badge.fury.io/py/flake8-variables-names.svg)](https://badge.fury.io/py/flake8-variables-names)
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/flake8-variables-names)
+
+An extension for flake8 that helps to make more readable variables names.
+
+We believe, that variable name should unmistakably shows, what it contains.
+Thats why we try not to use varnames with only one symbol or not to use
+too common names, such as `result`, `value` or `info`.
+
+This extensions helps to detect such names. By default it works in
+non-strict mode. You can change it with `--use-varnames-strict-mode`
+parameter end extend variable names blacklist even more.
+
+## Installation
+
+```terminal
+pip install flake8-variables-names
+```
+
+## Example
+
+Sample file:
+
+```python
+# test.py
+
+a = 1
+foo = 2
+result = a + foo
+```
+
+Usage:
+
+```terminal
+$ flake8 test.py
+test.py:1:1: VNE001 single letter variable names are not allowed
+test.py:2:1: VNE002 variable name should be clarified
+```
+
+## Error codes
+
+| Error code | Description |
+|:----------:|:-------------------------------------------------------:|
+| VNE001 | single letter variable names like 'XXX' are not allowed |
+| VNE002 | variable name 'XXX' should be clarified |
+| VNE003 | variable names that shadow builtins are not allowed |
+
+## Contributing
+
+We would love you to contribute to our project. It's simple:
+
+- Create an issue with bug you found or proposal you have.
+ Wait for approve from maintainer.
+- Create a pull request. Make sure all checks are green.
+- Fix review comments if any.
+- Be awesome.
+
+Here are useful tips:
+
+- You can run all checks and tests with `make check`.
+ Please do it before CI does.
+- We use [BestDoctor python styleguide](https://github.com/best-doctor/guides/blob/master/guides/en/python_styleguide.md).
+- We respect [Django CoC](https://www.djangoproject.com/conduct/).
+ Make soft, not bullshit.
+
+
+
+
+%prep
+%autosetup -n flake8-variables-names-0.0.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-flake8-variables-names -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.5-1
+- Package Spec generated