summaryrefslogtreecommitdiff
path: root/python-flask-cachebuster.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-cachebuster.spec')
-rw-r--r--python-flask-cachebuster.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-flask-cachebuster.spec b/python-flask-cachebuster.spec
new file mode 100644
index 0000000..86654d5
--- /dev/null
+++ b/python-flask-cachebuster.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Flask-CacheBuster
+Version: 1.0.0
+Release: 1
+Summary: Flask-CacheBuster is a lightweight Flask extension that adds a hash to the URL query parameters of each static file.
+License: MIT
+URL: https://github.com/israel-fl/Flask-CacheBuster
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/74/47/f3e1fedfaad965c81c2f17234636d72f71450f1b4522ca26d2b7eb4a0a74/Flask-CacheBuster-1.0.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Flask-CacheBuster is a lightweight http://flask.pocoo.org/ extension that adds a hash to the URL query parameters of each static file. This lets you safely declare your static resources as indefinitely cacheable because they automatically get new URLs when their contents change.
+
+%package -n python3-Flask-CacheBuster
+Summary: Flask-CacheBuster is a lightweight Flask extension that adds a hash to the URL query parameters of each static file.
+Provides: python-Flask-CacheBuster
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Flask-CacheBuster
+Flask-CacheBuster is a lightweight http://flask.pocoo.org/ extension that adds a hash to the URL query parameters of each static file. This lets you safely declare your static resources as indefinitely cacheable because they automatically get new URLs when their contents change.
+
+%package help
+Summary: Development documents and examples for Flask-CacheBuster
+Provides: python3-Flask-CacheBuster-doc
+%description help
+Flask-CacheBuster is a lightweight http://flask.pocoo.org/ extension that adds a hash to the URL query parameters of each static file. This lets you safely declare your static resources as indefinitely cacheable because they automatically get new URLs when their contents change.
+
+%prep
+%autosetup -n Flask-CacheBuster-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Flask-CacheBuster -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated