summaryrefslogtreecommitdiff
path: root/python-flask-cas.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-cas.spec')
-rw-r--r--python-flask-cas.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-flask-cas.spec b/python-flask-cas.spec
new file mode 100644
index 0000000..b19db37
--- /dev/null
+++ b/python-flask-cas.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Flask-CAS
+Version: 1.0.2
+Release: 1
+Summary: Flask extension for CAS
+License: BSD License
+URL: https://github.com/cameronbwhite/Flask-CAS
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/77/4d/ea64ad7e996820e3ff4f40f7c423834b01e8951061398f291068bf287064/Flask-CAS-1.0.2.tar.gz
+BuildArch: noarch
+
+
+%description
+Flask-CAS is a Flask extension which makes it easy to
+authenticate with a CAS.
+
+%package -n python3-Flask-CAS
+Summary: Flask extension for CAS
+Provides: python-Flask-CAS
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Flask-CAS
+Flask-CAS is a Flask extension which makes it easy to
+authenticate with a CAS.
+
+%package help
+Summary: Development documents and examples for Flask-CAS
+Provides: python3-Flask-CAS-doc
+%description help
+Flask-CAS is a Flask extension which makes it easy to
+authenticate with a CAS.
+
+%prep
+%autosetup -n Flask-CAS-1.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Flask-CAS -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
+- Package Spec generated