summaryrefslogtreecommitdiff
path: root/python-flask-cors.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-cors.spec')
-rw-r--r--python-flask-cors.spec92
1 files changed, 92 insertions, 0 deletions
diff --git a/python-flask-cors.spec b/python-flask-cors.spec
new file mode 100644
index 0000000..3fdf4c5
--- /dev/null
+++ b/python-flask-cors.spec
@@ -0,0 +1,92 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Flask-Cors
+Version: 3.0.10
+Release: 1
+Summary: A Flask extension adding a decorator for CORS support
+License: MIT
+URL: https://github.com/corydolphin/flask-cors
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/25/e3b2553d22ed542be807739556c69621ad2ab276ae8d5d2560f4ed20f652/Flask-Cors-3.0.10.tar.gz
+BuildArch: noarch
+
+Requires: python3-Flask
+Requires: python3-Six
+
+%description
+|Build Status| |Latest Version| |Supported Python versions|
+|License|
+A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible.
+This package has a simple philosophy: when you want to enable CORS, you wish to enable it for all use cases on a domain.
+This means no mucking around with different allowed headers, methods, etc.
+By default, submission of cookies across domains is disabled due to the security implications.
+Please see the documentation for how to enable credential'ed requests, and please make sure you add some sort of `CSRF <http://en.wikipedia.org/wiki/Cross-site_request_forgery>`__ protection before doing so!
+
+%package -n python3-Flask-Cors
+Summary: A Flask extension adding a decorator for CORS support
+Provides: python-Flask-Cors
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Flask-Cors
+|Build Status| |Latest Version| |Supported Python versions|
+|License|
+A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible.
+This package has a simple philosophy: when you want to enable CORS, you wish to enable it for all use cases on a domain.
+This means no mucking around with different allowed headers, methods, etc.
+By default, submission of cookies across domains is disabled due to the security implications.
+Please see the documentation for how to enable credential'ed requests, and please make sure you add some sort of `CSRF <http://en.wikipedia.org/wiki/Cross-site_request_forgery>`__ protection before doing so!
+
+%package help
+Summary: Development documents and examples for Flask-Cors
+Provides: python3-Flask-Cors-doc
+%description help
+|Build Status| |Latest Version| |Supported Python versions|
+|License|
+A Flask extension for handling Cross Origin Resource Sharing (CORS), making cross-origin AJAX possible.
+This package has a simple philosophy: when you want to enable CORS, you wish to enable it for all use cases on a domain.
+This means no mucking around with different allowed headers, methods, etc.
+By default, submission of cookies across domains is disabled due to the security implications.
+Please see the documentation for how to enable credential'ed requests, and please make sure you add some sort of `CSRF <http://en.wikipedia.org/wiki/Cross-site_request_forgery>`__ protection before doing so!
+
+%prep
+%autosetup -n Flask-Cors-3.0.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Flask-Cors -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.10-1
+- Package Spec generated