summaryrefslogtreecommitdiff
path: root/python-flask-monitoringdashboard.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-monitoringdashboard.spec')
-rw-r--r--python-flask-monitoringdashboard.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-flask-monitoringdashboard.spec b/python-flask-monitoringdashboard.spec
new file mode 100644
index 0000000..98acb0b
--- /dev/null
+++ b/python-flask-monitoringdashboard.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Flask-MonitoringDashboard
+Version: 3.1.1
+Release: 1
+Summary: Automatically monitor the evolving performance of Flask/Python web services.
+License: MIT License
+URL: https://github.com/flask-dashboard/Flask-MonitoringDashboard
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/56/5a/808dcbd85561f2148654d28b1eeabdf7c13090d987d1ae1857edc3abc346/Flask-MonitoringDashboard-3.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-click
+Requires: python3-apscheduler
+Requires: python3-flask
+Requires: python3-sqlalchemy
+Requires: python3-configparser
+Requires: python3-psutil
+Requires: python3-colorhash
+Requires: python3-numpy
+Requires: python3-pytz
+Requires: python3-tzlocal
+Requires: python3-scipy
+
+%description
+A dashboard for automatic monitoring of Flask (http://flask.pocoo.org/) web-services.
+
+%package -n python3-Flask-MonitoringDashboard
+Summary: Automatically monitor the evolving performance of Flask/Python web services.
+Provides: python-Flask-MonitoringDashboard
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Flask-MonitoringDashboard
+A dashboard for automatic monitoring of Flask (http://flask.pocoo.org/) web-services.
+
+%package help
+Summary: Development documents and examples for Flask-MonitoringDashboard
+Provides: python3-Flask-MonitoringDashboard-doc
+%description help
+A dashboard for automatic monitoring of Flask (http://flask.pocoo.org/) web-services.
+
+%prep
+%autosetup -n Flask-MonitoringDashboard-3.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Flask-MonitoringDashboard -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.1-1
+- Package Spec generated