summaryrefslogtreecommitdiff
path: root/python-flask-restless.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-flask-restless.spec')
-rw-r--r--python-flask-restless.spec108
1 files changed, 108 insertions, 0 deletions
diff --git a/python-flask-restless.spec b/python-flask-restless.spec
new file mode 100644
index 0000000..682889e
--- /dev/null
+++ b/python-flask-restless.spec
@@ -0,0 +1,108 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Flask-Restless
+Version: 0.17.0
+Release: 1
+Summary: A Flask extension for easy ReSTful API generation
+License: GNU AGPLv3+ or BSD
+URL: http://github.com/jfinkels/flask-restless
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ae/ad/14eee74ef110f2bd8641de98675037f037dd06d614f7c435671be66a55c7/Flask-Restless-0.17.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Flask-Restless
+ ~~~~~~~~~~~~~~
+
+ Flask-Restless is a `Flask <http://flask.pocoo.org>`_ extension which
+ facilitates the creation of ReSTful JSON APIs. It is compatible with models
+ which have been defined using `SQLAlchemy <http://sqlalchemy.org>`_ or
+ `FLask-SQLAlchemy <http://packages.python.org/Flask-SQLAlchemy>`_.
+
+ For more information, check the World Wide Web!
+
+ * `Documentation <http://readthedocs.org/docs/flask-restless>`_
+ * `PyPI listing <http://pypi.python.org/pypi/Flask-Restless>`_
+ * `Source code repository <http://github.com/jfinkels/flask-restless>`_
+
+%package -n python3-Flask-Restless
+Summary: A Flask extension for easy ReSTful API generation
+Provides: python-Flask-Restless
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Flask-Restless
+Flask-Restless
+ ~~~~~~~~~~~~~~
+
+ Flask-Restless is a `Flask <http://flask.pocoo.org>`_ extension which
+ facilitates the creation of ReSTful JSON APIs. It is compatible with models
+ which have been defined using `SQLAlchemy <http://sqlalchemy.org>`_ or
+ `FLask-SQLAlchemy <http://packages.python.org/Flask-SQLAlchemy>`_.
+
+ For more information, check the World Wide Web!
+
+ * `Documentation <http://readthedocs.org/docs/flask-restless>`_
+ * `PyPI listing <http://pypi.python.org/pypi/Flask-Restless>`_
+ * `Source code repository <http://github.com/jfinkels/flask-restless>`_
+
+%package help
+Summary: Development documents and examples for Flask-Restless
+Provides: python3-Flask-Restless-doc
+%description help
+Flask-Restless
+ ~~~~~~~~~~~~~~
+
+ Flask-Restless is a `Flask <http://flask.pocoo.org>`_ extension which
+ facilitates the creation of ReSTful JSON APIs. It is compatible with models
+ which have been defined using `SQLAlchemy <http://sqlalchemy.org>`_ or
+ `FLask-SQLAlchemy <http://packages.python.org/Flask-SQLAlchemy>`_.
+
+ For more information, check the World Wide Web!
+
+ * `Documentation <http://readthedocs.org/docs/flask-restless>`_
+ * `PyPI listing <http://pypi.python.org/pypi/Flask-Restless>`_
+ * `Source code repository <http://github.com/jfinkels/flask-restless>`_
+
+%prep
+%autosetup -n Flask-Restless-0.17.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Flask-Restless -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.17.0-1
+- Package Spec generated