summaryrefslogtreecommitdiff
path: root/python-ftd2xx.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ftd2xx.spec')
-rw-r--r--python-ftd2xx.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-ftd2xx.spec b/python-ftd2xx.spec
new file mode 100644
index 0000000..7cedd2d
--- /dev/null
+++ b/python-ftd2xx.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ftd2xx
+Version: 1.3.3
+Release: 1
+Summary: Python interface to ftd2xx.dll from FTDI using ctypesbased on d2xx by Pablo Bleyer
+License: MIT
+URL: https://github.com/snmishra/ftd2xx
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/94/e5/56c5a4b3d530c13540e2dd392deaf1b3a4f0ab55990542cf16afea16e2e7/ftd2xx-1.3.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-pywin32
+Requires: python3-typing-extensions
+Requires: python3-async-timeout
+
+%description
+
+
+%package -n python3-ftd2xx
+Summary: Python interface to ftd2xx.dll from FTDI using ctypesbased on d2xx by Pablo Bleyer
+Provides: python-ftd2xx
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ftd2xx
+
+
+%package help
+Summary: Development documents and examples for ftd2xx
+Provides: python3-ftd2xx-doc
+%description help
+
+
+%prep
+%autosetup -n ftd2xx-1.3.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ftd2xx -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.3-1
+- Package Spec generated