summaryrefslogtreecommitdiff
path: root/python-geckodriver-autoinstaller.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-geckodriver-autoinstaller.spec')
-rw-r--r--python-geckodriver-autoinstaller.spec156
1 files changed, 156 insertions, 0 deletions
diff --git a/python-geckodriver-autoinstaller.spec b/python-geckodriver-autoinstaller.spec
new file mode 100644
index 0000000..9d5ede0
--- /dev/null
+++ b/python-geckodriver-autoinstaller.spec
@@ -0,0 +1,156 @@
+%global _empty_manifest_terminate_build 0
+Name: python-geckodriver-autoinstaller
+Version: 0.1.0
+Release: 1
+Summary: Automatically install geckodriver that supports the currently installed version of chrome.
+License: MIT
+URL: https://github.com/yeongbin-jo/python-geckodriver-autoinstaller
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c7/bf/f7fa0998e7afeeed402f6706866eca36d6c2ebbf9447f4d425a6447552ea/geckodriver-autoinstaller-0.1.0.tar.gz
+BuildArch: noarch
+
+
+%description
+# geckodriver-autoinstaller
+Automatically download and install [geckodriver](https://github.com/mozilla/geckodriver/releases/latest) that supports the currently installed version of firefox. This installer supports Linux, MacOS and Windows operating systems.
+
+## Installation
+
+```bash
+pip install geckodriver-autoinstaller
+```
+
+## Usage
+Just type `import geckodriver_autoinstaller` in the module you want to use geckodriver.
+
+## Example
+```
+from selenium import webdriver
+import geckodriver_autoinstaller
+
+
+geckodriver_autoinstaller.install() # Check if the current version of geckodriver exists
+ # and if it doesn't exist, download it automatically,
+ # then add geckodriver to path
+
+driver = webdriver.Firefox()
+driver.get("http://www.python.org")
+assert "Python" in driver.title
+```
+
+
+
+
+%package -n python3-geckodriver-autoinstaller
+Summary: Automatically install geckodriver that supports the currently installed version of chrome.
+Provides: python-geckodriver-autoinstaller
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-geckodriver-autoinstaller
+# geckodriver-autoinstaller
+Automatically download and install [geckodriver](https://github.com/mozilla/geckodriver/releases/latest) that supports the currently installed version of firefox. This installer supports Linux, MacOS and Windows operating systems.
+
+## Installation
+
+```bash
+pip install geckodriver-autoinstaller
+```
+
+## Usage
+Just type `import geckodriver_autoinstaller` in the module you want to use geckodriver.
+
+## Example
+```
+from selenium import webdriver
+import geckodriver_autoinstaller
+
+
+geckodriver_autoinstaller.install() # Check if the current version of geckodriver exists
+ # and if it doesn't exist, download it automatically,
+ # then add geckodriver to path
+
+driver = webdriver.Firefox()
+driver.get("http://www.python.org")
+assert "Python" in driver.title
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for geckodriver-autoinstaller
+Provides: python3-geckodriver-autoinstaller-doc
+%description help
+# geckodriver-autoinstaller
+Automatically download and install [geckodriver](https://github.com/mozilla/geckodriver/releases/latest) that supports the currently installed version of firefox. This installer supports Linux, MacOS and Windows operating systems.
+
+## Installation
+
+```bash
+pip install geckodriver-autoinstaller
+```
+
+## Usage
+Just type `import geckodriver_autoinstaller` in the module you want to use geckodriver.
+
+## Example
+```
+from selenium import webdriver
+import geckodriver_autoinstaller
+
+
+geckodriver_autoinstaller.install() # Check if the current version of geckodriver exists
+ # and if it doesn't exist, download it automatically,
+ # then add geckodriver to path
+
+driver = webdriver.Firefox()
+driver.get("http://www.python.org")
+assert "Python" in driver.title
+```
+
+
+
+
+%prep
+%autosetup -n geckodriver-autoinstaller-0.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-geckodriver-autoinstaller -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.0-1
+- Package Spec generated