summaryrefslogtreecommitdiff
path: root/python-genmod.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-genmod.spec')
-rw-r--r--python-genmod.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-genmod.spec b/python-genmod.spec
new file mode 100644
index 0000000..e371b45
--- /dev/null
+++ b/python-genmod.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-genmod
+Version: 3.7.4
+Release: 1
+Summary: Annotate genetic inheritance models in variant files
+License: MIT License
+URL: http://github.com/moonso/genmod
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/79/10/20e0b6015af74923dbca3f538522cfa40b409183b400efbb3e8e051f745c/genmod-3.7.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-ped-parser
+Requires: python3-pytabix
+Requires: python3-pytest
+Requires: python3-interval-tree
+Requires: python3-click
+Requires: python3-configobj
+Requires: python3-intervaltree
+Requires: python3-extract-vcf
+
+%description
+Tool for annotating patterns of genetic inheritance in Variant Call Format (VCF) files.
+
+
+
+
+%package -n python3-genmod
+Summary: Annotate genetic inheritance models in variant files
+Provides: python-genmod
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-genmod
+Tool for annotating patterns of genetic inheritance in Variant Call Format (VCF) files.
+
+
+
+
+%package help
+Summary: Development documents and examples for genmod
+Provides: python3-genmod-doc
+%description help
+Tool for annotating patterns of genetic inheritance in Variant Call Format (VCF) files.
+
+
+
+
+%prep
+%autosetup -n genmod-3.7.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-genmod -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.7.4-1
+- Package Spec generated