summaryrefslogtreecommitdiff
path: root/python-geojson.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-09 11:26:02 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-09 11:26:02 +0000
commit38f2dd2a6fe686a741e78b8e12672ec088ca408b (patch)
tree3f2b75fcd95f0d7b33b851c08121a0e39b8af996 /python-geojson.spec
parent919258d2131ef7684c65bddeadb0c68e548c4d77 (diff)
automatic import of python-geojson
Diffstat (limited to 'python-geojson.spec')
-rw-r--r--python-geojson.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-geojson.spec b/python-geojson.spec
new file mode 100644
index 0000000..f22947c
--- /dev/null
+++ b/python-geojson.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-geojson
+Version: 3.0.1
+Release: 1
+Summary: Python bindings and utilities for GeoJSON
+License: BSD
+URL: https://github.com/jazzband/geojson
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1e/17/4f866d92f74ac1dcca4dad1665ce2e54c8feb861cd6e4b20de4fbf9b5f7b/geojson-3.0.1.tar.gz
+BuildArch: noarch
+
+
+%description
+This Python library contains:
+- Functions for encoding and decoding GeoJSON_ formatted data
+- Classes for all GeoJSON Objects
+- An implementation of the Python `__geo_interface__ Specification`_
+**Table of Contents**
+
+%package -n python3-geojson
+Summary: Python bindings and utilities for GeoJSON
+Provides: python-geojson
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-geojson
+This Python library contains:
+- Functions for encoding and decoding GeoJSON_ formatted data
+- Classes for all GeoJSON Objects
+- An implementation of the Python `__geo_interface__ Specification`_
+**Table of Contents**
+
+%package help
+Summary: Development documents and examples for geojson
+Provides: python3-geojson-doc
+%description help
+This Python library contains:
+- Functions for encoding and decoding GeoJSON_ formatted data
+- Classes for all GeoJSON Objects
+- An implementation of the Python `__geo_interface__ Specification`_
+**Table of Contents**
+
+%prep
+%autosetup -n geojson-3.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-geojson -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.1-1
+- Package Spec generated