summaryrefslogtreecommitdiff
path: root/python-georasters.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-georasters.spec')
-rw-r--r--python-georasters.spec142
1 files changed, 142 insertions, 0 deletions
diff --git a/python-georasters.spec b/python-georasters.spec
new file mode 100644
index 0000000..eae1bf9
--- /dev/null
+++ b/python-georasters.spec
@@ -0,0 +1,142 @@
+%global _empty_manifest_terminate_build 0
+Name: python-georasters
+Version: 0.5.24
+Release: 1
+Summary: Tools for working with Geographical Information System Rasters
+License: GPLv3
+URL: http://github.com/ozak/georasters
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/13/e6/55126620f586a0a7050471e451444566498d6d2b00fa53e929a6ab0a58b7/georasters-0.5.24.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-docopt
+Requires: python3-GDAL
+Requires: python3-pyproj
+Requires: python3-scikit-image
+Requires: python3-matplotlib
+Requires: python3-coverage
+Requires: python3-fiona
+Requires: python3-geopandas
+Requires: python3-pysal
+Requires: python3-affine
+Requires: python3-rasterstats
+
+%description
+|PyPiVersion|_
+|PyPiDownloads|_
+|BuildStatus|_
+|CoverageStatus|_
+The ``GeoRasters`` package is a python module that provides a fast and flexible
+tool to work with GIS raster files. It provides the GeoRaster class, which makes working with rasters quite transparent and easy.
+In a way it tries to do for rasters what GeoPandas does for geometries.
+It includes tools to
+- Merge rasters
+- Plot rasters
+- Extract information from rasters
+- Given a point (lat,lon) find its location in a raster
+- Aggregate rasters to lower resolutions
+- Align two rasters of different sizes to common area and size
+- Get all the geographical information of raster
+- Create GeoTiff files easily
+- Load GeoTiff files as masked numpy rasters
+- Clip raster using geometries
+- Get zonal statistics using geometries
+- Spatial analysis tools
+
+%package -n python3-georasters
+Summary: Tools for working with Geographical Information System Rasters
+Provides: python-georasters
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-georasters
+|PyPiVersion|_
+|PyPiDownloads|_
+|BuildStatus|_
+|CoverageStatus|_
+The ``GeoRasters`` package is a python module that provides a fast and flexible
+tool to work with GIS raster files. It provides the GeoRaster class, which makes working with rasters quite transparent and easy.
+In a way it tries to do for rasters what GeoPandas does for geometries.
+It includes tools to
+- Merge rasters
+- Plot rasters
+- Extract information from rasters
+- Given a point (lat,lon) find its location in a raster
+- Aggregate rasters to lower resolutions
+- Align two rasters of different sizes to common area and size
+- Get all the geographical information of raster
+- Create GeoTiff files easily
+- Load GeoTiff files as masked numpy rasters
+- Clip raster using geometries
+- Get zonal statistics using geometries
+- Spatial analysis tools
+
+%package help
+Summary: Development documents and examples for georasters
+Provides: python3-georasters-doc
+%description help
+|PyPiVersion|_
+|PyPiDownloads|_
+|BuildStatus|_
+|CoverageStatus|_
+The ``GeoRasters`` package is a python module that provides a fast and flexible
+tool to work with GIS raster files. It provides the GeoRaster class, which makes working with rasters quite transparent and easy.
+In a way it tries to do for rasters what GeoPandas does for geometries.
+It includes tools to
+- Merge rasters
+- Plot rasters
+- Extract information from rasters
+- Given a point (lat,lon) find its location in a raster
+- Aggregate rasters to lower resolutions
+- Align two rasters of different sizes to common area and size
+- Get all the geographical information of raster
+- Create GeoTiff files easily
+- Load GeoTiff files as masked numpy rasters
+- Clip raster using geometries
+- Get zonal statistics using geometries
+- Spatial analysis tools
+
+%prep
+%autosetup -n georasters-0.5.24
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-georasters -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.24-1
+- Package Spec generated