summaryrefslogtreecommitdiff
path: root/python-gmm-demux.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-gmm-demux.spec')
-rw-r--r--python-gmm-demux.spec16
1 files changed, 8 insertions, 8 deletions
diff --git a/python-gmm-demux.spec b/python-gmm-demux.spec
index d9db2c4..43601fc 100644
--- a/python-gmm-demux.spec
+++ b/python-gmm-demux.spec
@@ -5,7 +5,7 @@ Release: 1
Summary: A multiplet removal tool for processing cell hashing data
License: MIT License
URL: https://github.com/CHPGenetics/GMM-demux
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a4/e6/8cdb23eaf6e3c7b03a960acb11590ba6397deba9ac7258fc05ab2c7b855d/GMM_Demux-0.2.1.3.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/a4/e6/8cdb23eaf6e3c7b03a960acb11590ba6397deba9ac7258fc05ab2c7b855d/GMM_Demux-0.2.1.3.tar.gz
BuildArch: noarch
Requires: python3-pandas
@@ -822,7 +822,7 @@ Special thank to Zhongli Xu for testing GMM-Demux!
%prep
-%autosetup -n GMM-Demux-0.2.1.3
+%autosetup -n GMM_Demux-0.2.1.3
%build
%py3_build
@@ -836,20 +836,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -862,5 +862,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1.3-1
+* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1.3-1
- Package Spec generated