summaryrefslogtreecommitdiff
path: root/python-google-cloud-kms.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-google-cloud-kms.spec')
-rw-r--r--python-google-cloud-kms.spec86
1 files changed, 86 insertions, 0 deletions
diff --git a/python-google-cloud-kms.spec b/python-google-cloud-kms.spec
new file mode 100644
index 0000000..a9402b9
--- /dev/null
+++ b/python-google-cloud-kms.spec
@@ -0,0 +1,86 @@
+%global _empty_manifest_terminate_build 0
+Name: python-google-cloud-kms
+Version: 2.16.1
+Release: 1
+Summary: Google Cloud Kms API client library
+License: Apache 2.0
+URL: https://github.com/googleapis/python-kms
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c5/7a/afc516e1f28f86b6a6172d7cffbd848b77f85e7e0a0b5762c6b8d6cc319f/google-cloud-kms-2.16.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-google-api-core[grpc]
+Requires: python3-proto-plus
+Requires: python3-protobuf
+Requires: python3-grpc-google-iam-v1
+Requires: python3-proto-plus
+
+%description
+|stable| |pypi| |versions|
+`Google Cloud Key Management Service API`_: a cloud-hosted key management service that lets you manage cryptographic keys for your cloud services the same way you do on-premises. You can generate, use, rotate, and destroy AES256, RSA 2048, RSA 3072, RSA 4096, EC P256, and EC P384 cryptographic keys. Cloud KMS is integrated with Cloud IAM and Cloud Audit Logging so that you can manage permissions on individual keys and monitor how these are used. Use Cloud KMS to protect secrets and other sensitive data that you need to store in Google Cloud Platform.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%package -n python3-google-cloud-kms
+Summary: Google Cloud Kms API client library
+Provides: python-google-cloud-kms
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-google-cloud-kms
+|stable| |pypi| |versions|
+`Google Cloud Key Management Service API`_: a cloud-hosted key management service that lets you manage cryptographic keys for your cloud services the same way you do on-premises. You can generate, use, rotate, and destroy AES256, RSA 2048, RSA 3072, RSA 4096, EC P256, and EC P384 cryptographic keys. Cloud KMS is integrated with Cloud IAM and Cloud Audit Logging so that you can manage permissions on individual keys and monitor how these are used. Use Cloud KMS to protect secrets and other sensitive data that you need to store in Google Cloud Platform.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%package help
+Summary: Development documents and examples for google-cloud-kms
+Provides: python3-google-cloud-kms-doc
+%description help
+|stable| |pypi| |versions|
+`Google Cloud Key Management Service API`_: a cloud-hosted key management service that lets you manage cryptographic keys for your cloud services the same way you do on-premises. You can generate, use, rotate, and destroy AES256, RSA 2048, RSA 3072, RSA 4096, EC P256, and EC P384 cryptographic keys. Cloud KMS is integrated with Cloud IAM and Cloud Audit Logging so that you can manage permissions on individual keys and monitor how these are used. Use Cloud KMS to protect secrets and other sensitive data that you need to store in Google Cloud Platform.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%prep
+%autosetup -n google-cloud-kms-2.16.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-google-cloud-kms -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.16.1-1
+- Package Spec generated