summaryrefslogtreecommitdiff
path: root/python-google-cloud-service-directory.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-google-cloud-service-directory.spec')
-rw-r--r--python-google-cloud-service-directory.spec86
1 files changed, 86 insertions, 0 deletions
diff --git a/python-google-cloud-service-directory.spec b/python-google-cloud-service-directory.spec
new file mode 100644
index 0000000..cbb0552
--- /dev/null
+++ b/python-google-cloud-service-directory.spec
@@ -0,0 +1,86 @@
+%global _empty_manifest_terminate_build 0
+Name: python-google-cloud-service-directory
+Version: 1.8.1
+Release: 1
+Summary: Google Cloud Service Directory API client library
+License: Apache 2.0
+URL: https://github.com/googleapis/python-service-directory
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a0/22/7bc13a08367bf0cd3e395204a4914aec5d6f301277c85238e03972f6d4b1/google-cloud-service-directory-1.8.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-google-api-core[grpc]
+Requires: python3-proto-plus
+Requires: python3-protobuf
+Requires: python3-grpc-google-iam-v1
+Requires: python3-proto-plus
+
+%description
+|stable| |pypi| |versions|
+`Service Directory API`_: Allows the registration and lookup of services.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%package -n python3-google-cloud-service-directory
+Summary: Google Cloud Service Directory API client library
+Provides: python-google-cloud-service-directory
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-google-cloud-service-directory
+|stable| |pypi| |versions|
+`Service Directory API`_: Allows the registration and lookup of services.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%package help
+Summary: Development documents and examples for google-cloud-service-directory
+Provides: python3-google-cloud-service-directory-doc
+%description help
+|stable| |pypi| |versions|
+`Service Directory API`_: Allows the registration and lookup of services.
+- `Client Library Documentation`_
+- `Product Documentation`_
+
+%prep
+%autosetup -n google-cloud-service-directory-1.8.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-google-cloud-service-directory -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.8.1-1
+- Package Spec generated