summaryrefslogtreecommitdiff
path: root/python-google-gax.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 14:27:55 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 14:27:55 +0000
commitc2e7307e7e4564430d4d85adc791d2818156bcff (patch)
treefd75eb6435ee68dd619dd7ad6b2ff1586eaad76a /python-google-gax.spec
parent5af1ac49a9ac4eb604d6f33b18089bb570c186c9 (diff)
automatic import of python-google-gax
Diffstat (limited to 'python-google-gax.spec')
-rw-r--r--python-google-gax.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-google-gax.spec b/python-google-gax.spec
new file mode 100644
index 0000000..d7ad10c
--- /dev/null
+++ b/python-google-gax.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-google-gax
+Version: 0.16.0
+Release: 1
+Summary: Google API Extensions
+License: BSD-3-Clause
+URL: https://github.com/googleapis/gax-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ba/b9/b69dbba75101fb1a392bcb2ebce2e5d50f7c887634a3c6bbd36a000e35f8/google-gax-0.16.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-dill
+Requires: python3-future
+Requires: python3-googleapis-common-protos
+Requires: python3-grpcio
+Requires: python3-google-auth
+Requires: python3-ply
+Requires: python3-protobuf
+Requires: python3-requests
+
+%description
+This project has been deprecated and will no longer be developed. It has
+been wholly replaced by `google-api-core`_.
+
+%package -n python3-google-gax
+Summary: Google API Extensions
+Provides: python-google-gax
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-google-gax
+This project has been deprecated and will no longer be developed. It has
+been wholly replaced by `google-api-core`_.
+
+%package help
+Summary: Development documents and examples for google-gax
+Provides: python3-google-gax-doc
+%description help
+This project has been deprecated and will no longer be developed. It has
+been wholly replaced by `google-api-core`_.
+
+%prep
+%autosetup -n google-gax-0.16.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-google-gax -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.16.0-1
+- Package Spec generated