summaryrefslogtreecommitdiff
path: root/python-greenstalk.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-greenstalk.spec')
-rw-r--r--python-greenstalk.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-greenstalk.spec b/python-greenstalk.spec
new file mode 100644
index 0000000..d302bdb
--- /dev/null
+++ b/python-greenstalk.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-greenstalk
+Version: 2.0.0
+Release: 1
+Summary: A Python 3 client for the beanstalkd work queue
+License: MIT
+URL: https://github.com/justinmayhew/greenstalk
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/63/92/f95b2708d83ddf154ed4a25280d39b8ff97ffa27b0880aa6ab52f7f4ba46/greenstalk-2.0.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Greenstalk is a small and unopinionated Python client library for communicating
+with the `beanstalkd`_ work queue. The API provided mostly maps one-to-one with
+commands in the `protocol`_.
+
+%package -n python3-greenstalk
+Summary: A Python 3 client for the beanstalkd work queue
+Provides: python-greenstalk
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-greenstalk
+Greenstalk is a small and unopinionated Python client library for communicating
+with the `beanstalkd`_ work queue. The API provided mostly maps one-to-one with
+commands in the `protocol`_.
+
+%package help
+Summary: Development documents and examples for greenstalk
+Provides: python3-greenstalk-doc
+%description help
+Greenstalk is a small and unopinionated Python client library for communicating
+with the `beanstalkd`_ work queue. The API provided mostly maps one-to-one with
+commands in the `protocol`_.
+
+%prep
+%autosetup -n greenstalk-2.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-greenstalk -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.0-1
+- Package Spec generated