summaryrefslogtreecommitdiff
path: root/python-greynoise.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-greynoise.spec')
-rw-r--r--python-greynoise.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-greynoise.spec b/python-greynoise.spec
new file mode 100644
index 0000000..28144aa
--- /dev/null
+++ b/python-greynoise.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-greynoise
+Version: 2.0.1
+Release: 1
+Summary: Abstraction to interact with GreyNoise API.
+License: MIT
+URL: https://greynoise.io/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5a/bb/b60b0a199d38c2fd71edb83b91fe982b9ec7535b22381012e1ee47426144/greynoise-2.0.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-Click
+Requires: python3-ansimarkup
+Requires: python3-cachetools
+Requires: python3-colorama
+Requires: python3-click-default-group
+Requires: python3-click-repl
+Requires: python3-dict2xml
+Requires: python3-ipaddress
+Requires: python3-jinja2
+Requires: python3-more-itertools
+Requires: python3-requests
+Requires: python3-six
+
+%description
+
+
+%package -n python3-greynoise
+Summary: Abstraction to interact with GreyNoise API.
+Provides: python-greynoise
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-greynoise
+
+
+%package help
+Summary: Development documents and examples for greynoise
+Provides: python3-greynoise-doc
+%description help
+
+
+%prep
+%autosetup -n greynoise-2.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-greynoise -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.1-1
+- Package Spec generated