summaryrefslogtreecommitdiff
path: root/python-gtools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-gtools.spec')
-rw-r--r--python-gtools.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-gtools.spec b/python-gtools.spec
new file mode 100644
index 0000000..518e7fe
--- /dev/null
+++ b/python-gtools.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Gtools
+Version: 0.16
+Release: 1
+Summary: UNKNOWN
+License: Creative Commons Attribution-Noncommercial-Share Alike license
+URL: http://www.nbhosting.nl/dist/gtools/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/84/ea/2049d746fc5a3063b2453db79b64afc2545b8e8bb0fbae45a9e1b24ca13a/Gtools-0.16.tar.gz
+BuildArch: noarch
+
+
+%description
+Function: checktags
+This function matches any tags like ##TAGNAME##
+if there any wrong tags it returns false else it returns true
+
+%package -n python3-Gtools
+Summary: UNKNOWN
+Provides: python-Gtools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Gtools
+Function: checktags
+This function matches any tags like ##TAGNAME##
+if there any wrong tags it returns false else it returns true
+
+%package help
+Summary: Development documents and examples for Gtools
+Provides: python3-Gtools-doc
+%description help
+Function: checktags
+This function matches any tags like ##TAGNAME##
+if there any wrong tags it returns false else it returns true
+
+%prep
+%autosetup -n Gtools-0.16
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Gtools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.16-1
+- Package Spec generated