summaryrefslogtreecommitdiff
path: root/python-health-check.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-health-check.spec')
-rw-r--r--python-health-check.spec121
1 files changed, 121 insertions, 0 deletions
diff --git a/python-health-check.spec b/python-health-check.spec
new file mode 100644
index 0000000..f5d1d4c
--- /dev/null
+++ b/python-health-check.spec
@@ -0,0 +1,121 @@
+%global _empty_manifest_terminate_build 0
+Name: python-health-check
+Version: 3.4.1
+Release: 1
+Summary: Health Check is an application that provides an API to check the health health_check of some parts and some utilities like ping requests. This application can works as standalone or included in a Django project.
+License: GPLv3
+URL: https://github.com/PeRDy/health-check
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e2/9e/95799c9d4feada474da20b3b9107a32d15fb405ca61a77479c10407f9fe1/health-check-3.4.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-GitPython
+Requires: python3-pyyaml
+Requires: python3-clinner
+Requires: python3-setuptools
+Requires: python3-pip
+Requires: python3-wheel
+Requires: python3-twine
+Requires: python3-bumpversion
+Requires: python3-pre-commit
+Requires: python3-GitPython
+Requires: python3-pyyaml
+Requires: python3-clinner
+Requires: python3-coverage
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-prospector
+Requires: python3-tox
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+
+%description
+1. Install this package using pip:
+ pip install health-check
+2. *(Django)* Add *PROJECT_PATH* to your django settings module.
+3. *(Django)* Add *health_check* to your **INSTALLED_APPS** settings like this:
+ INSTALLED_APPS = (
+ 'health_check',
+ )
+4. *(Django)* Add **Health Check** urls to your project urls:
+ urlpatterns = [
+ url(r'^health/', include('health_check.urls')),
+ ]
+
+%package -n python3-health-check
+Summary: Health Check is an application that provides an API to check the health health_check of some parts and some utilities like ping requests. This application can works as standalone or included in a Django project.
+Provides: python-health-check
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-health-check
+1. Install this package using pip:
+ pip install health-check
+2. *(Django)* Add *PROJECT_PATH* to your django settings module.
+3. *(Django)* Add *health_check* to your **INSTALLED_APPS** settings like this:
+ INSTALLED_APPS = (
+ 'health_check',
+ )
+4. *(Django)* Add **Health Check** urls to your project urls:
+ urlpatterns = [
+ url(r'^health/', include('health_check.urls')),
+ ]
+
+%package help
+Summary: Development documents and examples for health-check
+Provides: python3-health-check-doc
+%description help
+1. Install this package using pip:
+ pip install health-check
+2. *(Django)* Add *PROJECT_PATH* to your django settings module.
+3. *(Django)* Add *health_check* to your **INSTALLED_APPS** settings like this:
+ INSTALLED_APPS = (
+ 'health_check',
+ )
+4. *(Django)* Add **Health Check** urls to your project urls:
+ urlpatterns = [
+ url(r'^health/', include('health_check.urls')),
+ ]
+
+%prep
+%autosetup -n health-check-3.4.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-health-check -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.4.1-1
+- Package Spec generated