summaryrefslogtreecommitdiff
path: root/python-hipersim.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-hipersim.spec')
-rw-r--r--python-hipersim.spec144
1 files changed, 144 insertions, 0 deletions
diff --git a/python-hipersim.spec b/python-hipersim.spec
new file mode 100644
index 0000000..698c415
--- /dev/null
+++ b/python-hipersim.spec
@@ -0,0 +1,144 @@
+%global _empty_manifest_terminate_build 0
+Name: python-hipersim
+Version: 0.0.25
+Release: 1
+Summary: A collection of wind energy simulation tools
+License: MIT License
+URL: https://gitlab.windenergy.dtu.dk/HiperSim/hipersim
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b9/2a/24425ca430d6f3b5178c4e6d45de6dfd8b8b74abb098a7e1a3c91c615cbc/hipersim-0.0.25.tar.gz
+BuildArch: noarch
+
+
+%description
+# Hipersim
+
+## Introduction
+Hipersim is a collection of tools for computationally-efficient simulation of Wind Energy problems using statistical and machine learning methods. Currently, the package contains the following submodules:
+
+- **turbgen**:
+ - Generation of 3D frozen turbulence fields ("turbulence boxes") with the Mann turbulence spectrum
+ - Constrained turbulence field generation and application of constraints on pre-generated turbulence fields
+
+- **surrogates**:
+ - A feedforward neural network toolbox, training and evaluation of feedforward neural networks.
+ - A set of tools for surrogate-based modeling and analysis of wind farms
+
+## Installation
+Hipersim is registered as installable Python package in PyPi.org. Installation happens automatically with the following command:
+
+pip install hipersim
+
+## References
+
+## License
+Hipersim uses the MIT License.
+
+
+
+
+%package -n python3-hipersim
+Summary: A collection of wind energy simulation tools
+Provides: python-hipersim
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-hipersim
+# Hipersim
+
+## Introduction
+Hipersim is a collection of tools for computationally-efficient simulation of Wind Energy problems using statistical and machine learning methods. Currently, the package contains the following submodules:
+
+- **turbgen**:
+ - Generation of 3D frozen turbulence fields ("turbulence boxes") with the Mann turbulence spectrum
+ - Constrained turbulence field generation and application of constraints on pre-generated turbulence fields
+
+- **surrogates**:
+ - A feedforward neural network toolbox, training and evaluation of feedforward neural networks.
+ - A set of tools for surrogate-based modeling and analysis of wind farms
+
+## Installation
+Hipersim is registered as installable Python package in PyPi.org. Installation happens automatically with the following command:
+
+pip install hipersim
+
+## References
+
+## License
+Hipersim uses the MIT License.
+
+
+
+
+%package help
+Summary: Development documents and examples for hipersim
+Provides: python3-hipersim-doc
+%description help
+# Hipersim
+
+## Introduction
+Hipersim is a collection of tools for computationally-efficient simulation of Wind Energy problems using statistical and machine learning methods. Currently, the package contains the following submodules:
+
+- **turbgen**:
+ - Generation of 3D frozen turbulence fields ("turbulence boxes") with the Mann turbulence spectrum
+ - Constrained turbulence field generation and application of constraints on pre-generated turbulence fields
+
+- **surrogates**:
+ - A feedforward neural network toolbox, training and evaluation of feedforward neural networks.
+ - A set of tools for surrogate-based modeling and analysis of wind farms
+
+## Installation
+Hipersim is registered as installable Python package in PyPi.org. Installation happens automatically with the following command:
+
+pip install hipersim
+
+## References
+
+## License
+Hipersim uses the MIT License.
+
+
+
+
+%prep
+%autosetup -n hipersim-0.0.25
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-hipersim -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.25-1
+- Package Spec generated