summaryrefslogtreecommitdiff
path: root/python-honeypots.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 03:25:45 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 03:25:45 +0000
commit58e285b999454e1781a610d3b5248eb330455778 (patch)
treef95c6e7597fdabfcb7d0f7b3d96df5c90ec6ab07 /python-honeypots.spec
parentfb41908dca2ba76ba6b0988a361b7494417a20d8 (diff)
automatic import of python-honeypots
Diffstat (limited to 'python-honeypots.spec')
-rw-r--r--python-honeypots.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/python-honeypots.spec b/python-honeypots.spec
new file mode 100644
index 0000000..9b27df1
--- /dev/null
+++ b/python-honeypots.spec
@@ -0,0 +1,95 @@
+%global _empty_manifest_terminate_build 0
+Name: python-honeypots
+Version: 0.62
+Release: 1
+Summary: 27 different honeypots in a single pypi package! (dns, ftp, httpproxy, http, https, imap, mysql, pop3, postgres, redis, smb, smtp, socks5, ssh, telnet, vnc, mssql, elastic, ldap, ntp, memcache, snmp, oracle, dhcp, rdp, sip and irc)
+License: AGPL-3.0
+URL: https://github.com/qeeqbox/honeypots
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/60/2d/3c1066349e84f4a1bf1fef13b92bf77b92781354c7af91129209b0ddfc9b/honeypots-0.62.tar.gz
+BuildArch: noarch
+
+Requires: python3-twisted
+Requires: python3-psutil
+Requires: python3-psycopg2-binary
+Requires: python3-pycrypto
+Requires: python3-requests
+Requires: python3-requests[socks]
+Requires: python3-impacket
+Requires: python3-paramiko
+Requires: python3-scapy
+Requires: python3-service-identity
+Requires: python3-netifaces
+Requires: python3-redis
+Requires: python3-mysql-connector
+Requires: python3-elasticsearch
+Requires: python3-pymssql
+Requires: python3-ldap3
+Requires: python3-pysnmp
+
+%description
+The honeypots respond back, non-blocking, can be used as objects, or called directly with the in-built auto-configure scripts! Also, they are easy to setup and customize, it takes 1-2 seconds to spin a honeypot up. You can spin up multiple instances with the same type. The output can be logged to a Postgres database, file[s], terminal or syslog for easy integration.
+This honeypots package is the only package that contains all the following: dhcp, dns, elastic, ftp, http_proxy, http, https, imap, ipp, irc, ldap, memcache, mssql, mysql, ntp, oracle, pjl, pop3, postgres, rdp, redis, sip, smb, smtp, snmp, socks5, ssh, telnet, vnc.
+Honeypots now is in the awesome `telekom security T-Pot project! <https://github.com/telekom-security/tpotce>`_
+
+%package -n python3-honeypots
+Summary: 27 different honeypots in a single pypi package! (dns, ftp, httpproxy, http, https, imap, mysql, pop3, postgres, redis, smb, smtp, socks5, ssh, telnet, vnc, mssql, elastic, ldap, ntp, memcache, snmp, oracle, dhcp, rdp, sip and irc)
+Provides: python-honeypots
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-honeypots
+The honeypots respond back, non-blocking, can be used as objects, or called directly with the in-built auto-configure scripts! Also, they are easy to setup and customize, it takes 1-2 seconds to spin a honeypot up. You can spin up multiple instances with the same type. The output can be logged to a Postgres database, file[s], terminal or syslog for easy integration.
+This honeypots package is the only package that contains all the following: dhcp, dns, elastic, ftp, http_proxy, http, https, imap, ipp, irc, ldap, memcache, mssql, mysql, ntp, oracle, pjl, pop3, postgres, rdp, redis, sip, smb, smtp, snmp, socks5, ssh, telnet, vnc.
+Honeypots now is in the awesome `telekom security T-Pot project! <https://github.com/telekom-security/tpotce>`_
+
+%package help
+Summary: Development documents and examples for honeypots
+Provides: python3-honeypots-doc
+%description help
+The honeypots respond back, non-blocking, can be used as objects, or called directly with the in-built auto-configure scripts! Also, they are easy to setup and customize, it takes 1-2 seconds to spin a honeypot up. You can spin up multiple instances with the same type. The output can be logged to a Postgres database, file[s], terminal or syslog for easy integration.
+This honeypots package is the only package that contains all the following: dhcp, dns, elastic, ftp, http_proxy, http, https, imap, ipp, irc, ldap, memcache, mssql, mysql, ntp, oracle, pjl, pop3, postgres, rdp, redis, sip, smb, smtp, snmp, socks5, ssh, telnet, vnc.
+Honeypots now is in the awesome `telekom security T-Pot project! <https://github.com/telekom-security/tpotce>`_
+
+%prep
+%autosetup -n honeypots-0.62
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-honeypots -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.62-1
+- Package Spec generated