summaryrefslogtreecommitdiff
path: root/python-hopic.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 06:59:06 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 06:59:06 +0000
commita127fb56a0457a91a5a16afd79450f1ffd7cc14f (patch)
tree5719a4955f233bf58bb4c8f8dcb1e194e0db816d /python-hopic.spec
parentb85a965b72b15f63c38864fa9ff3fa8283e5d544 (diff)
automatic import of python-hopic
Diffstat (limited to 'python-hopic.spec')
-rw-r--r--python-hopic.spec99
1 files changed, 99 insertions, 0 deletions
diff --git a/python-hopic.spec b/python-hopic.spec
new file mode 100644
index 0000000..5fc1f55
--- /dev/null
+++ b/python-hopic.spec
@@ -0,0 +1,99 @@
+%global _empty_manifest_terminate_build 0
+Name: python-hopic
+Version: 1.60.0
+Release: 1
+Summary: In order to simplify the CI configuration we are switching away from the generic jenkins shared pipeline which is completely written in Groovy. Instead we are switching to the Hopic project which only has a minimal CI driver component written in Groovy with the rest written in Python. With Hopic local debugging is made significantly easier.
+License: Apache License 2.0
+URL: https://github.com/tomtom-international/hopic
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/42/22/32de442223ba80a631b13fdedb9f460cd89d103f52f918bead9a76d8df8a/hopic-1.60.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Click
+Requires: python3-click-log
+Requires: python3-commisery
+Requires: python3-GitPython
+Requires: python3-dateutil
+Requires: python3-PyYAML
+Requires: python3-setuptools
+Requires: python3-typeguard
+Requires: python3-importlib-metadata
+Requires: python3-typing-extensions
+Requires: python3-keyring
+Requires: python3-netstruct
+
+%description
+**Install the hopic** command with below package
+ pip3 install --user 'git+https://github.com/tomtom-international/hopic.git@release/1#egg=hopic[interactive]'
+**Enable TAB completion** - include the below line in your .bashrc ( BashComplete_ )
+ eval "$(_HOPIC_COMPLETE=source hopic)"
+For the command line help on hopic usage
+ hopic --help
+
+%package -n python3-hopic
+Summary: In order to simplify the CI configuration we are switching away from the generic jenkins shared pipeline which is completely written in Groovy. Instead we are switching to the Hopic project which only has a minimal CI driver component written in Groovy with the rest written in Python. With Hopic local debugging is made significantly easier.
+Provides: python-hopic
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-hopic
+**Install the hopic** command with below package
+ pip3 install --user 'git+https://github.com/tomtom-international/hopic.git@release/1#egg=hopic[interactive]'
+**Enable TAB completion** - include the below line in your .bashrc ( BashComplete_ )
+ eval "$(_HOPIC_COMPLETE=source hopic)"
+For the command line help on hopic usage
+ hopic --help
+
+%package help
+Summary: Development documents and examples for hopic
+Provides: python3-hopic-doc
+%description help
+**Install the hopic** command with below package
+ pip3 install --user 'git+https://github.com/tomtom-international/hopic.git@release/1#egg=hopic[interactive]'
+**Enable TAB completion** - include the below line in your .bashrc ( BashComplete_ )
+ eval "$(_HOPIC_COMPLETE=source hopic)"
+For the command line help on hopic usage
+ hopic --help
+
+%prep
+%autosetup -n hopic-1.60.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-hopic -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.60.0-1
+- Package Spec generated