summaryrefslogtreecommitdiff
path: root/python-hpfeeds-logger.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-hpfeeds-logger.spec')
-rw-r--r--python-hpfeeds-logger.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-hpfeeds-logger.spec b/python-hpfeeds-logger.spec
new file mode 100644
index 0000000..8d855d0
--- /dev/null
+++ b/python-hpfeeds-logger.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-hpfeeds-logger
+Version: 0.0.7.7
+Release: 1
+Summary: Python library to normalize and log hpfeeds honeypot messages
+License: License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)
+URL: https://github.com/threatstream/hpfeeds-logger
+Source0: https://mirrors.aliyun.com/pypi/web/packages/c0/bd/f7c119ea6bc6c9646e2113a7454bd60c1a9fffd7733e33dd942d2a9f748a/hpfeeds-logger-0.0.7.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-hpfeeds-threatstream
+Requires: python3-geoip2
+
+%description
+A library for consuming messages from hpfeeds honeypots and normalizing them
+
+
+
+
+%package -n python3-hpfeeds-logger
+Summary: Python library to normalize and log hpfeeds honeypot messages
+Provides: python-hpfeeds-logger
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-hpfeeds-logger
+A library for consuming messages from hpfeeds honeypots and normalizing them
+
+
+
+
+%package help
+Summary: Development documents and examples for hpfeeds-logger
+Provides: python3-hpfeeds-logger-doc
+%description help
+A library for consuming messages from hpfeeds honeypots and normalizing them
+
+
+
+
+%prep
+%autosetup -n hpfeeds-logger-0.0.7.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-hpfeeds-logger -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.7.7-1
+- Package Spec generated