summaryrefslogtreecommitdiff
path: root/python-image-match.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 10:02:15 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 10:02:15 +0000
commit1574b56e945147e50d35131a8ebe037e20f0d02f (patch)
treec8a562722f420cd536d6aed426d762d8f339eb0f /python-image-match.spec
parent6f6257efdfe195b607353f2ae0279769c89ced3a (diff)
automatic import of python-image-matchopeneuler20.03
Diffstat (limited to 'python-image-match.spec')
-rw-r--r--python-image-match.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-image-match.spec b/python-image-match.spec
new file mode 100644
index 0000000..6537bde
--- /dev/null
+++ b/python-image-match.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-image-match
+Version: 1.1.2
+Release: 1
+Summary: image_match is a simple package for finding approximate image matches from a corpus.
+License: Apache License 2.0
+URL: https://github.com/ascribe/image-match/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/da/ed/5d16b10e6f83520205d16b434c844d749a0c4c9df5505b85f76787c887c0/image_match-1.1.2.tar.gz
+BuildArch: noarch
+
+
+%description
+image_match is a simple package for finding approximate image matches from a
+corpus. It is similar, for instance, to pHash <http://www.phash.org/>, but
+includes a database backend that easily scales to billions of images and
+supports sustained high rates of image insertion: up to 10,000 images/s on our
+cluster!
+
+Based on the paper An image signature for any kind of image, Goldberg et
+al <http://www.cs.cmu.edu/~hcwong/Pdfs/icip02.ps>.
+
+%package -n python3-image-match
+Summary: image_match is a simple package for finding approximate image matches from a corpus.
+Provides: python-image-match
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-image-match
+image_match is a simple package for finding approximate image matches from a
+corpus. It is similar, for instance, to pHash <http://www.phash.org/>, but
+includes a database backend that easily scales to billions of images and
+supports sustained high rates of image insertion: up to 10,000 images/s on our
+cluster!
+
+Based on the paper An image signature for any kind of image, Goldberg et
+al <http://www.cs.cmu.edu/~hcwong/Pdfs/icip02.ps>.
+
+%package help
+Summary: Development documents and examples for image-match
+Provides: python3-image-match-doc
+%description help
+image_match is a simple package for finding approximate image matches from a
+corpus. It is similar, for instance, to pHash <http://www.phash.org/>, but
+includes a database backend that easily scales to billions of images and
+supports sustained high rates of image insertion: up to 10,000 images/s on our
+cluster!
+
+Based on the paper An image signature for any kind of image, Goldberg et
+al <http://www.cs.cmu.edu/~hcwong/Pdfs/icip02.ps>.
+
+%prep
+%autosetup -n image_match-1.1.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-image-match -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.2-1
+- Package Spec generated