summaryrefslogtreecommitdiff
path: root/python-image-slicer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-image-slicer.spec')
-rw-r--r--python-image-slicer.spec16
1 files changed, 8 insertions, 8 deletions
diff --git a/python-image-slicer.spec b/python-image-slicer.spec
index cf45008..bb5fe58 100644
--- a/python-image-slicer.spec
+++ b/python-image-slicer.spec
@@ -5,7 +5,7 @@ Release: 1
Summary: Split images into tiles. Join the tiles back together.
License: MIT license
URL: https://github.com/samdobson/image_slicer
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/17/72/e1afeef7cf8bf441c1471abbc2565314fca1144fa819b1b04fdd85f2953a/image_slicer-2.1.1.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/17/72/e1afeef7cf8bf441c1471abbc2565314fca1144fa819b1b04fdd85f2953a/image_slicer-2.1.1.tar.gz
BuildArch: noarch
Requires: python3-Pillow
@@ -120,7 +120,7 @@ For full package documentation please visit [samdobson.github.io/image_slicer](h
See [CONTRIBUTING.md](CONTRIBUTING.md) for details.
%prep
-%autosetup -n image-slicer-2.1.1
+%autosetup -n image_slicer-2.1.1
%build
%py3_build
@@ -134,20 +134,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -160,5 +160,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1-1
+* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1-1
- Package Spec generated