summaryrefslogtreecommitdiff
path: root/python-imagedata.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-imagedata.spec')
-rw-r--r--python-imagedata.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-imagedata.spec b/python-imagedata.spec
new file mode 100644
index 0000000..876763e
--- /dev/null
+++ b/python-imagedata.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-imagedata
+Version: 2.1.2
+Release: 1
+Summary: Read/write medical image data
+License: MIT
+URL: https://github.com/erling6232/imagedata
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/ca/8e7669962e7473ffcc502e32a98d6fe093d632bae401c7ad6aa6a42e8c71/imagedata-2.1.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-sortedcontainers
+Requires: python3-pydicom
+Requires: python3-pynetdicom
+Requires: python3-itk-io
+Requires: python3-scikit-build
+Requires: python3-nibabel
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-scipy
+Requires: python3-magic
+Requires: python3-imageio
+Requires: python3-xnat
+Requires: python3-matplotlib
+Requires: python3-magic-bin
+Requires: python3-importlib-metadata
+Requires: python3-itk-io
+Requires: python3-itk-io
+
+%description
+ pip install imagedata
+
+%package -n python3-imagedata
+Summary: Read/write medical image data
+Provides: python-imagedata
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-imagedata
+ pip install imagedata
+
+%package help
+Summary: Development documents and examples for imagedata
+Provides: python3-imagedata-doc
+%description help
+ pip install imagedata
+
+%prep
+%autosetup -n imagedata-2.1.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-imagedata -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.2-1
+- Package Spec generated