summaryrefslogtreecommitdiff
path: root/python-imap-tools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-imap-tools.spec')
-rw-r--r--python-imap-tools.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-imap-tools.spec b/python-imap-tools.spec
new file mode 100644
index 0000000..708a159
--- /dev/null
+++ b/python-imap-tools.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-imap-tools
+Version: 1.0.0
+Release: 1
+Summary: Work with email by IMAP
+License: Apache-2.0
+URL: https://github.com/ikvk/imap_tools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7c/91/287526663b51f06812bd20ecb142dc636e43b2394f6cd5c6167d57a12972/imap-tools-1.0.0.tar.gz
+BuildArch: noarch
+
+
+%description
+High level lib for work with email by IMAP:
+- Basic message operations: fetch, uids, numbers
+- Parsed email message attributes
+- Query builder for search criteria
+- Actions with emails: copy, delete, flag, move, append
+- Actions with folders: list, set, get, create, exists, rename, subscribe, delete, status
+- IDLE commands: start, poll, stop, wait
+- Exceptions on failed IMAP operations
+
+%package -n python3-imap-tools
+Summary: Work with email by IMAP
+Provides: python-imap-tools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-imap-tools
+High level lib for work with email by IMAP:
+- Basic message operations: fetch, uids, numbers
+- Parsed email message attributes
+- Query builder for search criteria
+- Actions with emails: copy, delete, flag, move, append
+- Actions with folders: list, set, get, create, exists, rename, subscribe, delete, status
+- IDLE commands: start, poll, stop, wait
+- Exceptions on failed IMAP operations
+
+%package help
+Summary: Development documents and examples for imap-tools
+Provides: python3-imap-tools-doc
+%description help
+High level lib for work with email by IMAP:
+- Basic message operations: fetch, uids, numbers
+- Parsed email message attributes
+- Query builder for search criteria
+- Actions with emails: copy, delete, flag, move, append
+- Actions with folders: list, set, get, create, exists, rename, subscribe, delete, status
+- IDLE commands: start, poll, stop, wait
+- Exceptions on failed IMAP operations
+
+%prep
+%autosetup -n imap-tools-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-imap-tools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated