summaryrefslogtreecommitdiff
path: root/python-imgio.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-imgio.spec')
-rw-r--r--python-imgio.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-imgio.spec b/python-imgio.spec
new file mode 100644
index 0000000..61bd5f9
--- /dev/null
+++ b/python-imgio.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-imgio
+Version: 1.0.0
+Release: 1
+Summary: Easy image reading & writing.
+License: MIT
+URL: http://github.com/toaarnio/imgio
+Source0: https://mirrors.aliyun.com/pypi/web/packages/d2/2d/292152df283c82c2a617fc98af182d8e2e68886318a4e9f5a3e12844e6d6/imgio-1.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-imread
+Requires: python3-numpy
+Requires: python3-piexif
+
+%description
+
+
+%package -n python3-imgio
+Summary: Easy image reading & writing.
+Provides: python-imgio
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-imgio
+
+
+%package help
+Summary: Development documents and examples for imgio
+Provides: python3-imgio-doc
+%description help
+
+
+%prep
+%autosetup -n imgio-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-imgio -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated