summaryrefslogtreecommitdiff
path: root/python-import-order.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-import-order.spec')
-rw-r--r--python-import-order.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-import-order.spec b/python-import-order.spec
new file mode 100644
index 0000000..404de89
--- /dev/null
+++ b/python-import-order.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-import-order
+Version: 0.0.11
+Release: 1
+Summary: Check python import order.
+License: UNKNOWN
+URL: https://github.com/spoqa/import-order
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0f/11/d20bef3000425703ebc4102193c73d13fb64c302eef9c78b8630be582be8/import-order-0.0.11.tar.gz
+BuildArch: noarch
+
+
+%description
+CLI that check the ordering of imports. ordering follow a below rules.
+1. Module order: ``__future__`` , standard libraries, site-packages, local.
+2. ``CONSTANT_NAMES`` must be the first.
+3. ``ClassNames`` must be the second.
+4. Rest must be in alphabetical order.
+
+%package -n python3-import-order
+Summary: Check python import order.
+Provides: python-import-order
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-import-order
+CLI that check the ordering of imports. ordering follow a below rules.
+1. Module order: ``__future__`` , standard libraries, site-packages, local.
+2. ``CONSTANT_NAMES`` must be the first.
+3. ``ClassNames`` must be the second.
+4. Rest must be in alphabetical order.
+
+%package help
+Summary: Development documents and examples for import-order
+Provides: python3-import-order-doc
+%description help
+CLI that check the ordering of imports. ordering follow a below rules.
+1. Module order: ``__future__`` , standard libraries, site-packages, local.
+2. ``CONSTANT_NAMES`` must be the first.
+3. ``ClassNames`` must be the second.
+4. Rest must be in alphabetical order.
+
+%prep
+%autosetup -n import-order-0.0.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-import-order -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.11-1
+- Package Spec generated