summaryrefslogtreecommitdiff
path: root/python-iot-device.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-iot-device.spec')
-rw-r--r--python-iot-device.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-iot-device.spec b/python-iot-device.spec
new file mode 100644
index 0000000..61ffc7b
--- /dev/null
+++ b/python-iot-device.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-iot-device
+Version: 0.5.32
+Release: 1
+Summary: MicroPython REPL Interface
+License: MIT
+URL: https://github.com/iot49/iot-device
+Source0: https://mirrors.aliyun.com/pypi/web/packages/4e/ab/e78e44d22aa946f6620ef4c9f86e39c5628f6b7eb4b39dd43910e608a684/iot-device-0.5.32.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyserial
+Requires: python3-termcolor
+Requires: python3-pyopenssl
+Requires: python3-zeroconf
+Requires: python3-websocket-client
+Requires: python3-pyyaml
+
+%description
+Communication with MicroPython device over serial, internet, ...
+
+
+%package -n python3-iot-device
+Summary: MicroPython REPL Interface
+Provides: python-iot-device
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-iot-device
+Communication with MicroPython device over serial, internet, ...
+
+
+%package help
+Summary: Development documents and examples for iot-device
+Provides: python3-iot-device-doc
+%description help
+Communication with MicroPython device over serial, internet, ...
+
+
+%prep
+%autosetup -n iot-device-0.5.32
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-iot-device -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.32-1
+- Package Spec generated