summaryrefslogtreecommitdiff
path: root/python-ipinfo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ipinfo.spec')
-rw-r--r--python-ipinfo.spec99
1 files changed, 99 insertions, 0 deletions
diff --git a/python-ipinfo.spec b/python-ipinfo.spec
new file mode 100644
index 0000000..4ef54c8
--- /dev/null
+++ b/python-ipinfo.spec
@@ -0,0 +1,99 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ipinfo
+Version: 4.4.2
+Release: 1
+Summary: Official Python library for IPInfo
+License: Apache License 2.0
+URL: https://github.com/ipinfo/python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6c/0d/8ddc288380949b813109440cf6ec1995948d1ad04c367de191f2ab7d103b/ipinfo-4.4.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-cachetools
+Requires: python3-requests
+
+%description
+
+The official Python library for IPinfo.
+
+IPinfo prides itself on being the most reliable, accurate, and in-depth source of IP address data available anywhere.
+We process terabytes of data to produce our custom IP geolocation, company, carrier and IP type data sets.
+You can visit our developer docs at https://ipinfo.io/developers.
+
+
+
+
+%package -n python3-ipinfo
+Summary: Official Python library for IPInfo
+Provides: python-ipinfo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ipinfo
+
+The official Python library for IPinfo.
+
+IPinfo prides itself on being the most reliable, accurate, and in-depth source of IP address data available anywhere.
+We process terabytes of data to produce our custom IP geolocation, company, carrier and IP type data sets.
+You can visit our developer docs at https://ipinfo.io/developers.
+
+
+
+
+%package help
+Summary: Development documents and examples for ipinfo
+Provides: python3-ipinfo-doc
+%description help
+
+The official Python library for IPinfo.
+
+IPinfo prides itself on being the most reliable, accurate, and in-depth source of IP address data available anywhere.
+We process terabytes of data to produce our custom IP geolocation, company, carrier and IP type data sets.
+You can visit our developer docs at https://ipinfo.io/developers.
+
+
+
+
+%prep
+%autosetup -n ipinfo-4.4.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ipinfo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 4.4.2-1
+- Package Spec generated