summaryrefslogtreecommitdiff
path: root/python-javapmdbear.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 13:15:40 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 13:15:40 +0000
commit807e818a99ce9c7f44d523a23832b2054cb669c6 (patch)
tree4c22b507db37e82271d1fdfd27bef7293a3b93cd /python-javapmdbear.spec
parent4d229a1d83fa429a027dd0448becaa70215381ee (diff)
automatic import of python-javapmdbear
Diffstat (limited to 'python-javapmdbear.spec')
-rw-r--r--python-javapmdbear.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-javapmdbear.spec b/python-javapmdbear.spec
new file mode 100644
index 0000000..798245e
--- /dev/null
+++ b/python-javapmdbear.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-JavaPMDBear
+Version: 0.10.0
+Release: 1
+Summary: 'JavaPMDBear' bear for coala (http://coala.rtfd.org/)
+License: AGPL-3.0
+URL: https://pypi.org/project/JavaPMDBear/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b0/74/d7d781c54ae05d1f0305356a811623f68f171d9a40369bfe3e80363a7b68/JavaPMDBear-0.10.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Check Java code for possible issues like potential bugs, dead code or too
+ complicated expressions.
+
+ More information is available at
+ <http://pmd.github.io/pmd-5.4.1/pmd-java/rules/index.html>.
+
+%package -n python3-JavaPMDBear
+Summary: 'JavaPMDBear' bear for coala (http://coala.rtfd.org/)
+Provides: python-JavaPMDBear
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-JavaPMDBear
+Check Java code for possible issues like potential bugs, dead code or too
+ complicated expressions.
+
+ More information is available at
+ <http://pmd.github.io/pmd-5.4.1/pmd-java/rules/index.html>.
+
+%package help
+Summary: Development documents and examples for JavaPMDBear
+Provides: python3-JavaPMDBear-doc
+%description help
+Check Java code for possible issues like potential bugs, dead code or too
+ complicated expressions.
+
+ More information is available at
+ <http://pmd.github.io/pmd-5.4.1/pmd-java/rules/index.html>.
+
+%prep
+%autosetup -n JavaPMDBear-0.10.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-JavaPMDBear -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.0-1
+- Package Spec generated