summaryrefslogtreecommitdiff
path: root/python-je-auto-control.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 03:52:10 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 03:52:10 +0000
commite3fa141557551393d970ac30681299d8b4a4e7e1 (patch)
tree245a7d9b613343e1d6e3fc0085be0e221c6f31c9 /python-je-auto-control.spec
parent1d1e60e3723464f7c4ea1417e8cd771e0db562ee (diff)
automatic import of python-je-auto-controlopeneuler20.03
Diffstat (limited to 'python-je-auto-control.spec')
-rw-r--r--python-je-auto-control.spec111
1 files changed, 111 insertions, 0 deletions
diff --git a/python-je-auto-control.spec b/python-je-auto-control.spec
new file mode 100644
index 0000000..ce5da59
--- /dev/null
+++ b/python-je-auto-control.spec
@@ -0,0 +1,111 @@
+%global _empty_manifest_terminate_build 0
+Name: python-je-auto-control
+Version: 0.0.137
+Release: 1
+Summary: GUI Automation Framework
+License: MIT
+URL: https://github.com/Intergration-Automation-Testing/AutoControl
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c7/8a/6cc8236fa11424333822a1113b9207b2a99538988006f72ed9edb41115a1/je_auto_control-0.0.137.tar.gz
+BuildArch: noarch
+
+Requires: python3-je-open-cv
+Requires: python3-pillow
+Requires: python3-numpy
+Requires: python3-pyobjc-core
+Requires: python3-pyobjc
+Requires: python3-Xlib
+
+%description
+> Project Kanban \
+> https://github.com/orgs/Intergration-Automation-Testing/projects/2 \
+> Image & Coordinate based GUI Automation \
+> GUI automated based on image comparison and coordinates. \
+> Cross-platform and cross-programming language.\
+> Solve problems:
+>> * Provide automation execution for repetitive tasks.
+>> * Multiple methods are available, including recording, image recognition, and coordinate-based testing.
+>> * Tests can be executed remotely through TCP/IP.
+>> * Test reports can be generated with records for each action.
+>> * The same code can be used for three platforms, reducing the possibility of platform-dependent programs.
+>> * Provide hooks for keyboard and mouse events and state checks (including using code to simulate key presses).
+
+%package -n python3-je-auto-control
+Summary: GUI Automation Framework
+Provides: python-je-auto-control
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-je-auto-control
+> Project Kanban \
+> https://github.com/orgs/Intergration-Automation-Testing/projects/2 \
+> Image & Coordinate based GUI Automation \
+> GUI automated based on image comparison and coordinates. \
+> Cross-platform and cross-programming language.\
+> Solve problems:
+>> * Provide automation execution for repetitive tasks.
+>> * Multiple methods are available, including recording, image recognition, and coordinate-based testing.
+>> * Tests can be executed remotely through TCP/IP.
+>> * Test reports can be generated with records for each action.
+>> * The same code can be used for three platforms, reducing the possibility of platform-dependent programs.
+>> * Provide hooks for keyboard and mouse events and state checks (including using code to simulate key presses).
+
+%package help
+Summary: Development documents and examples for je-auto-control
+Provides: python3-je-auto-control-doc
+%description help
+> Project Kanban \
+> https://github.com/orgs/Intergration-Automation-Testing/projects/2 \
+> Image & Coordinate based GUI Automation \
+> GUI automated based on image comparison and coordinates. \
+> Cross-platform and cross-programming language.\
+> Solve problems:
+>> * Provide automation execution for repetitive tasks.
+>> * Multiple methods are available, including recording, image recognition, and coordinate-based testing.
+>> * Tests can be executed remotely through TCP/IP.
+>> * Test reports can be generated with records for each action.
+>> * The same code can be used for three platforms, reducing the possibility of platform-dependent programs.
+>> * Provide hooks for keyboard and mouse events and state checks (including using code to simulate key presses).
+
+%prep
+%autosetup -n je-auto-control-0.0.137
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-je-auto-control -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.137-1
+- Package Spec generated