summaryrefslogtreecommitdiff
path: root/python-joulescope.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-joulescope.spec')
-rw-r--r--python-joulescope.spec216
1 files changed, 216 insertions, 0 deletions
diff --git a/python-joulescope.spec b/python-joulescope.spec
new file mode 100644
index 0000000..de390fd
--- /dev/null
+++ b/python-joulescope.spec
@@ -0,0 +1,216 @@
+%global _empty_manifest_terminate_build 0
+Name: python-joulescope
+Version: 1.1.4
+Release: 1
+Summary: Joulescope™ host driver and utilities
+License: Apache 2.0
+URL: https://joulescope.readthedocs.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/54/5a/7eb940b83552100e1cfeec936b3e9ea25c17dc333e413f98b57874710c0f/joulescope-1.1.4.tar.gz
+
+Requires: python3-numpy
+Requires: python3-psutil
+Requires: python3-pyjls
+Requires: python3-pyjoulescope-driver
+Requires: python3-dateutil
+Requires: python3-pymonocypher
+Requires: python3-pywin32
+Requires: python3-check-manifest
+Requires: python3-coverage
+Requires: python3-Cython
+Requires: python3-wheel
+Requires: python3-sphinx
+Requires: python3-myst-parser
+
+%description
+
+# ![Joulescope](https://download.joulescope.com/press/joulescope_logo-PNG-Transparent-Exact-Small.png "Joulescope Logo")
+
+[![Build Status](https://travis-ci.org/jetperch/pyjoulescope.svg?branch=master)](https://travis-ci.org/jetperch/pyjoulescope)
+[![Docs Status](https://readthedocs.org/projects/joulescope/badge/?version=latest)](https://joulescope.readthedocs.io/)
+
+Welcome to the Joulescope™ python driver!
+[Joulescope](https://www.joulescope.com) is an affordable, precision DC energy
+analyzer that enables you to build better products.
+
+This pyjoulescope python package enables you to
+automate Joulescope operation and easily measure current, voltage, power and
+energy within your own Python programs.
+With the Joulescope driver, controlling your Joulescope is easy. The following
+example captures 0.1 seconds of data and then prints the average current
+and voltage:
+
+ import joulescope
+ import numpy as np
+ with joulescope.scan_require_one(config='auto') as js:
+ data = js.read(contiguous_duration=0.1)
+ current, voltage = np.mean(data, axis=0, dtype=np.float64)
+ print(f'{current} A, {voltage} V')
+
+This package also installs the "joulescope" command line tool:
+
+ joulescope --help
+
+Most Joulescope users will run the graphical user interface which is in the
+[pyjoulescope_ui](https://github.com/jetperch/pyjoulescope_ui) package and
+available for [download](https://www.joulescope.com/download).
+
+
+## Documentation
+
+Visit the [documentation](https://joulescope.readthedocs.io) for details on
+installing and using this joulescope package.
+
+
+## License
+
+All pyjoulescope code is released under the permissive Apache 2.0 license.
+See the [License File](LICENSE.txt) for details.
+
+
+%package -n python3-joulescope
+Summary: Joulescope™ host driver and utilities
+Provides: python-joulescope
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-joulescope
+
+# ![Joulescope](https://download.joulescope.com/press/joulescope_logo-PNG-Transparent-Exact-Small.png "Joulescope Logo")
+
+[![Build Status](https://travis-ci.org/jetperch/pyjoulescope.svg?branch=master)](https://travis-ci.org/jetperch/pyjoulescope)
+[![Docs Status](https://readthedocs.org/projects/joulescope/badge/?version=latest)](https://joulescope.readthedocs.io/)
+
+Welcome to the Joulescope™ python driver!
+[Joulescope](https://www.joulescope.com) is an affordable, precision DC energy
+analyzer that enables you to build better products.
+
+This pyjoulescope python package enables you to
+automate Joulescope operation and easily measure current, voltage, power and
+energy within your own Python programs.
+With the Joulescope driver, controlling your Joulescope is easy. The following
+example captures 0.1 seconds of data and then prints the average current
+and voltage:
+
+ import joulescope
+ import numpy as np
+ with joulescope.scan_require_one(config='auto') as js:
+ data = js.read(contiguous_duration=0.1)
+ current, voltage = np.mean(data, axis=0, dtype=np.float64)
+ print(f'{current} A, {voltage} V')
+
+This package also installs the "joulescope" command line tool:
+
+ joulescope --help
+
+Most Joulescope users will run the graphical user interface which is in the
+[pyjoulescope_ui](https://github.com/jetperch/pyjoulescope_ui) package and
+available for [download](https://www.joulescope.com/download).
+
+
+## Documentation
+
+Visit the [documentation](https://joulescope.readthedocs.io) for details on
+installing and using this joulescope package.
+
+
+## License
+
+All pyjoulescope code is released under the permissive Apache 2.0 license.
+See the [License File](LICENSE.txt) for details.
+
+
+%package help
+Summary: Development documents and examples for joulescope
+Provides: python3-joulescope-doc
+%description help
+
+# ![Joulescope](https://download.joulescope.com/press/joulescope_logo-PNG-Transparent-Exact-Small.png "Joulescope Logo")
+
+[![Build Status](https://travis-ci.org/jetperch/pyjoulescope.svg?branch=master)](https://travis-ci.org/jetperch/pyjoulescope)
+[![Docs Status](https://readthedocs.org/projects/joulescope/badge/?version=latest)](https://joulescope.readthedocs.io/)
+
+Welcome to the Joulescope™ python driver!
+[Joulescope](https://www.joulescope.com) is an affordable, precision DC energy
+analyzer that enables you to build better products.
+
+This pyjoulescope python package enables you to
+automate Joulescope operation and easily measure current, voltage, power and
+energy within your own Python programs.
+With the Joulescope driver, controlling your Joulescope is easy. The following
+example captures 0.1 seconds of data and then prints the average current
+and voltage:
+
+ import joulescope
+ import numpy as np
+ with joulescope.scan_require_one(config='auto') as js:
+ data = js.read(contiguous_duration=0.1)
+ current, voltage = np.mean(data, axis=0, dtype=np.float64)
+ print(f'{current} A, {voltage} V')
+
+This package also installs the "joulescope" command line tool:
+
+ joulescope --help
+
+Most Joulescope users will run the graphical user interface which is in the
+[pyjoulescope_ui](https://github.com/jetperch/pyjoulescope_ui) package and
+available for [download](https://www.joulescope.com/download).
+
+
+## Documentation
+
+Visit the [documentation](https://joulescope.readthedocs.io) for details on
+installing and using this joulescope package.
+
+
+## License
+
+All pyjoulescope code is released under the permissive Apache 2.0 license.
+See the [License File](LICENSE.txt) for details.
+
+
+%prep
+%autosetup -n joulescope-1.1.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-joulescope -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.4-1
+- Package Spec generated