summaryrefslogtreecommitdiff
path: root/python-jschon.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-jschon.spec')
-rw-r--r--python-jschon.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-jschon.spec b/python-jschon.spec
new file mode 100644
index 0000000..df16af8
--- /dev/null
+++ b/python-jschon.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-jschon
+Version: 0.10.2
+Release: 1
+Summary: A pythonic, extensible JSON Schema implementation.
+License: MIT
+URL: https://github.com/marksparkza/jschon
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a5/d7/46ca28bac26bb687b7aae1d2fa81484cfb152612cfb3aa22dbec0b861d98/jschon-0.10.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-rfc3986
+Requires: python3-pytest
+Requires: python3-coverage
+Requires: python3-hypothesis
+Requires: python3-pytest-benchmark
+Requires: python3-pytest-httpserver
+Requires: python3-requests
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-requests
+Requires: python3-tox
+
+%description
+|tests| |codecov| |pypi| |python| |docs| |license|
+jschon is a pythonic and extensible implementation of the
+`JSON Schema <https://json-schema.org/>`_ specification.
+
+%package -n python3-jschon
+Summary: A pythonic, extensible JSON Schema implementation.
+Provides: python-jschon
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-jschon
+|tests| |codecov| |pypi| |python| |docs| |license|
+jschon is a pythonic and extensible implementation of the
+`JSON Schema <https://json-schema.org/>`_ specification.
+
+%package help
+Summary: Development documents and examples for jschon
+Provides: python3-jschon-doc
+%description help
+|tests| |codecov| |pypi| |python| |docs| |license|
+jschon is a pythonic and extensible implementation of the
+`JSON Schema <https://json-schema.org/>`_ specification.
+
+%prep
+%autosetup -n jschon-0.10.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-jschon -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.2-1
+- Package Spec generated