summaryrefslogtreecommitdiff
path: root/python-json-e.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-json-e.spec')
-rw-r--r--python-json-e.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/python-json-e.spec b/python-json-e.spec
new file mode 100644
index 0000000..e50a4b7
--- /dev/null
+++ b/python-json-e.spec
@@ -0,0 +1,88 @@
+%global _empty_manifest_terminate_build 0
+Name: python-json-e
+Version: 4.5.2
+Release: 1
+Summary: A data-structure parameterization system written for embedding context in JSON objects
+License: MPL2
+URL: https://json-e.js.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c3/1d/9c00415b118719f1deb353a444fb587a78226226248015165e7f924cb295/json-e-4.5.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-towncrier
+
+%description
+A data-structure parameterization system written for embedding context in JSON objects.
+
+See https://json-e.js.org for usage information.
+
+
+
+
+%package -n python3-json-e
+Summary: A data-structure parameterization system written for embedding context in JSON objects
+Provides: python-json-e
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-json-e
+A data-structure parameterization system written for embedding context in JSON objects.
+
+See https://json-e.js.org for usage information.
+
+
+
+
+%package help
+Summary: Development documents and examples for json-e
+Provides: python3-json-e-doc
+%description help
+A data-structure parameterization system written for embedding context in JSON objects.
+
+See https://json-e.js.org for usage information.
+
+
+
+
+%prep
+%autosetup -n json-e-4.5.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-json-e -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 4.5.2-1
+- Package Spec generated