summaryrefslogtreecommitdiff
path: root/python-jupyterlab-markup.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 06:30:30 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 06:30:30 +0000
commite8b9b012802cd3ec51964cd633ec9208ad593350 (patch)
tree722b942beecea578e31528cf3d8d2fe54571aa84 /python-jupyterlab-markup.spec
parent21b158b1048f4007d7675fa105329523ce607916 (diff)
automatic import of python-jupyterlab-markup
Diffstat (limited to 'python-jupyterlab-markup.spec')
-rw-r--r--python-jupyterlab-markup.spec337
1 files changed, 337 insertions, 0 deletions
diff --git a/python-jupyterlab-markup.spec b/python-jupyterlab-markup.spec
new file mode 100644
index 0000000..abbe6c7
--- /dev/null
+++ b/python-jupyterlab-markup.spec
@@ -0,0 +1,337 @@
+%global _empty_manifest_terminate_build 0
+Name: python-jupyterlab-markup
+Version: 2.0.0
+Release: 1
+Summary: Extensible markdown rendering support in markdown
+License: BSD-3-Clause
+URL: https://github.com/agoose77/jupyterlab-markup.git
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3a/92/2b06d513104d997fff1354e524f615ba7cc2315569c2bb46bce3c8c076e5/jupyterlab_markup-2.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-jupyterlab
+
+%description
+# jupyterlab_markup
+
+[![pypi-badge][]][pypi] [![binder-badge][]][binder] [![ci-badge][]][ci]
+
+[binder-badge]: https://mybinder.org/badge_logo.svg
+[binder]: https://mybinder.org/v2/gh/agoose77/jupyterlab-markup.git/main?urlpath=lab
+[pypi-badge]: https://img.shields.io/pypi/v/jupyterlab-markup
+[pypi]: https://pypi.org/project/jupyterlab-markup
+[ci-badge]: https://github.com/agoose77/jupyterlab-markup/actions/workflows/ci.yml/badge.svg
+[ci]: https://github.com/agoose77/jupyterlab-markup/actions/workflows/ci.yml
+
+Additional markdown rendering support in markdown.
+
+This extension is composed of a Python package named `jupyterlab_markup`
+for the server extension and a NPM package named `@agoose77/jupyterlab-markup`
+for the frontend extension.
+
+## Requirements
+
+- JupyterLab >= 3.0
+
+## Install
+
+```bash
+pip install jupyterlab_markup
+```
+
+## Troubleshoot
+
+If you are seeing the frontend extension, but it is not working, check
+that the server extension is enabled:
+
+```bash
+jupyter server extension list
+```
+
+If the server extension is installed and enabled, but you are not seeing
+the frontend extension, check the frontend extension is installed:
+
+```bash
+jupyter labextension list
+```
+
+## Contributing
+
+### Development install
+
+Note: You will need NodeJS to build the extension package.
+
+The `jlpm` command is JupyterLab's pinned version of
+[yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use
+`yarn` or `npm` in lieu of `jlpm` below.
+
+```bash
+# Clone the repo to your local environment
+# Change directory to the jupyterlab_markup directory
+# Install package in development mode
+pip install -e .
+# Link your development version of the extension with JupyterLab
+jupyter labextension develop . --overwrite
+# Rebuild extension Typescript source after making changes
+jlpm run build
+```
+
+You can watch the source directory and run JupyterLab at the same time in different terminals to watch for changes in the extension's source and automatically rebuild the extension.
+
+```bash
+# Watch the source directory in one terminal, automatically rebuilding when needed
+jlpm run watch
+# Run JupyterLab in another terminal
+jupyter lab
+```
+
+With the watch command running, every saved change will immediately be built locally and available in your running JupyterLab. Refresh JupyterLab to load the change in your browser (you may need to wait several seconds for the extension to be rebuilt).
+
+By default, the `jlpm run build` command generates the source maps for this extension to make it easier to debug using the browser dev tools. To also generate source maps for the JupyterLab core extensions, you can run the following command:
+
+```bash
+jupyter lab build --minimize=False
+```
+
+### Uninstall
+
+```bash
+pip uninstall jupyterlab_markup
+```
+
+
+
+
+%package -n python3-jupyterlab-markup
+Summary: Extensible markdown rendering support in markdown
+Provides: python-jupyterlab-markup
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-jupyterlab-markup
+# jupyterlab_markup
+
+[![pypi-badge][]][pypi] [![binder-badge][]][binder] [![ci-badge][]][ci]
+
+[binder-badge]: https://mybinder.org/badge_logo.svg
+[binder]: https://mybinder.org/v2/gh/agoose77/jupyterlab-markup.git/main?urlpath=lab
+[pypi-badge]: https://img.shields.io/pypi/v/jupyterlab-markup
+[pypi]: https://pypi.org/project/jupyterlab-markup
+[ci-badge]: https://github.com/agoose77/jupyterlab-markup/actions/workflows/ci.yml/badge.svg
+[ci]: https://github.com/agoose77/jupyterlab-markup/actions/workflows/ci.yml
+
+Additional markdown rendering support in markdown.
+
+This extension is composed of a Python package named `jupyterlab_markup`
+for the server extension and a NPM package named `@agoose77/jupyterlab-markup`
+for the frontend extension.
+
+## Requirements
+
+- JupyterLab >= 3.0
+
+## Install
+
+```bash
+pip install jupyterlab_markup
+```
+
+## Troubleshoot
+
+If you are seeing the frontend extension, but it is not working, check
+that the server extension is enabled:
+
+```bash
+jupyter server extension list
+```
+
+If the server extension is installed and enabled, but you are not seeing
+the frontend extension, check the frontend extension is installed:
+
+```bash
+jupyter labextension list
+```
+
+## Contributing
+
+### Development install
+
+Note: You will need NodeJS to build the extension package.
+
+The `jlpm` command is JupyterLab's pinned version of
+[yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use
+`yarn` or `npm` in lieu of `jlpm` below.
+
+```bash
+# Clone the repo to your local environment
+# Change directory to the jupyterlab_markup directory
+# Install package in development mode
+pip install -e .
+# Link your development version of the extension with JupyterLab
+jupyter labextension develop . --overwrite
+# Rebuild extension Typescript source after making changes
+jlpm run build
+```
+
+You can watch the source directory and run JupyterLab at the same time in different terminals to watch for changes in the extension's source and automatically rebuild the extension.
+
+```bash
+# Watch the source directory in one terminal, automatically rebuilding when needed
+jlpm run watch
+# Run JupyterLab in another terminal
+jupyter lab
+```
+
+With the watch command running, every saved change will immediately be built locally and available in your running JupyterLab. Refresh JupyterLab to load the change in your browser (you may need to wait several seconds for the extension to be rebuilt).
+
+By default, the `jlpm run build` command generates the source maps for this extension to make it easier to debug using the browser dev tools. To also generate source maps for the JupyterLab core extensions, you can run the following command:
+
+```bash
+jupyter lab build --minimize=False
+```
+
+### Uninstall
+
+```bash
+pip uninstall jupyterlab_markup
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for jupyterlab-markup
+Provides: python3-jupyterlab-markup-doc
+%description help
+# jupyterlab_markup
+
+[![pypi-badge][]][pypi] [![binder-badge][]][binder] [![ci-badge][]][ci]
+
+[binder-badge]: https://mybinder.org/badge_logo.svg
+[binder]: https://mybinder.org/v2/gh/agoose77/jupyterlab-markup.git/main?urlpath=lab
+[pypi-badge]: https://img.shields.io/pypi/v/jupyterlab-markup
+[pypi]: https://pypi.org/project/jupyterlab-markup
+[ci-badge]: https://github.com/agoose77/jupyterlab-markup/actions/workflows/ci.yml/badge.svg
+[ci]: https://github.com/agoose77/jupyterlab-markup/actions/workflows/ci.yml
+
+Additional markdown rendering support in markdown.
+
+This extension is composed of a Python package named `jupyterlab_markup`
+for the server extension and a NPM package named `@agoose77/jupyterlab-markup`
+for the frontend extension.
+
+## Requirements
+
+- JupyterLab >= 3.0
+
+## Install
+
+```bash
+pip install jupyterlab_markup
+```
+
+## Troubleshoot
+
+If you are seeing the frontend extension, but it is not working, check
+that the server extension is enabled:
+
+```bash
+jupyter server extension list
+```
+
+If the server extension is installed and enabled, but you are not seeing
+the frontend extension, check the frontend extension is installed:
+
+```bash
+jupyter labextension list
+```
+
+## Contributing
+
+### Development install
+
+Note: You will need NodeJS to build the extension package.
+
+The `jlpm` command is JupyterLab's pinned version of
+[yarn](https://yarnpkg.com/) that is installed with JupyterLab. You may use
+`yarn` or `npm` in lieu of `jlpm` below.
+
+```bash
+# Clone the repo to your local environment
+# Change directory to the jupyterlab_markup directory
+# Install package in development mode
+pip install -e .
+# Link your development version of the extension with JupyterLab
+jupyter labextension develop . --overwrite
+# Rebuild extension Typescript source after making changes
+jlpm run build
+```
+
+You can watch the source directory and run JupyterLab at the same time in different terminals to watch for changes in the extension's source and automatically rebuild the extension.
+
+```bash
+# Watch the source directory in one terminal, automatically rebuilding when needed
+jlpm run watch
+# Run JupyterLab in another terminal
+jupyter lab
+```
+
+With the watch command running, every saved change will immediately be built locally and available in your running JupyterLab. Refresh JupyterLab to load the change in your browser (you may need to wait several seconds for the extension to be rebuilt).
+
+By default, the `jlpm run build` command generates the source maps for this extension to make it easier to debug using the browser dev tools. To also generate source maps for the JupyterLab core extensions, you can run the following command:
+
+```bash
+jupyter lab build --minimize=False
+```
+
+### Uninstall
+
+```bash
+pip uninstall jupyterlab_markup
+```
+
+
+
+
+%prep
+%autosetup -n jupyterlab-markup-2.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-jupyterlab-markup -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.0-1
+- Package Spec generated