summaryrefslogtreecommitdiff
path: root/python-kerastroke.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-kerastroke.spec')
-rw-r--r--python-kerastroke.spec326
1 files changed, 326 insertions, 0 deletions
diff --git a/python-kerastroke.spec b/python-kerastroke.spec
new file mode 100644
index 0000000..5a5ee52
--- /dev/null
+++ b/python-kerastroke.spec
@@ -0,0 +1,326 @@
+%global _empty_manifest_terminate_build 0
+Name: python-kerastroke
+Version: 2.1.1
+Release: 1
+Summary: A suite of the generalization-improvement techniques Stroke, Pruning, and NeuroPlast
+License: MIT License
+URL: https://github.com/CharlesAverill/kerastroke/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/3c/4e/d74e798142e43eb3ec7129cce6704b7edaaded710e0dea8f1fb79e9d7175/kerastroke-2.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-tensorflow
+Requires: python3-numpy
+
+%description
+# KeraStroke
+
+KeraStroke is a [Python package](https://pypi.org/project/kerastroke/#description) that implements
+"Post-Back-propagation Weight Operations", or "PBWOs"; generalization-improvement techniques for Keras models in the
+form of custom Keras Callbacks. These techniques function
+similarly but have different philosophies and results. The techniques are:
+- Stroke: Re-initializaing random weight/bias values.
+- Pruning: Reducing model size by setting weight/bias values that are close to 0, to 0.
+- NeuroPlast: Re-initializing any weight/bias values that are 0 or close to 0.
+
+Stroke is modeled after seizures, which send random electrical signals throughout the brain, sometimes causing damage
+to synapses.
+
+NeuroPlast is modeled after the concept of neuroplasticity, when neurons that no longer have a primary function begin
+to rewire to improve another function. I started working on NeuroPlast after I read the work done by Blakemore and
+Cooper on horizontal/vertical line receptor neurons in the brains of cats.
+
+If you'd like to see the tests I'm performing with KeraStroke, you can view my testing repository
+[here](https://github.com/CharlesAverill/stroke-testing).
+
+KeraStroke 2.0.0 marks when I really started putting work into the project. I've made an effort to comment more,
+clean my code up, and make the package easier to understand overall without sacrificing utility.
+
+# Limitations
+KeraStroke is still in the development phase. Heavy testing has been done on
+Dense nets, but little testing has been done on CNNs and no testing has been done on RNNs. As of 2.1.0, CNNs are
+functioning properly in KeraStroke! The issue with previous versions had to do with the way the callback would retrieve
+ the weights from the models. The callbacks perform significantly better on DenseNets, but could still find use in CNNs.
+ I'm working on this, but will definitely need the help. Please see
+ [the github page](https://github.com/CharlesAverill/kerastroke/) or
+ [contact me](https://mail.google.com/mail/?view=cm&fs=1&to=charlesaverill20@gmail.com) to contribute to the project.
+
+# Stroke
+The goal of the Stroke callback is to re-initialize weights/biases that have begun to contribute to overfitting.
+
+Parameters:
+
+ - `set_value`: re-initialized weights will be set to this value, rather than a random one
+ - `low_bound`: low bound for weight re-initialization
+ - `high_bound`: high bound for weight re-initialization
+ - `volatility_ratio`: percentage of weights to be re-initialized
+ - `cutoff`: number of epochs to perform PBWOs
+ - `decay`: Every epoch, v_ratio is multiplied by this number. decay can be greater than 1.0,
+ but v_ratio will never exceed 1.0
+ - `do_weights`: perform stroke on weights
+ - `do_biases`: perform stroke on biases
+
+# Pruning
+The goal of the Pruning callback is to nullify weights/biases that are effectively 0.
+
+Parameters:
+
+ - `set_value`: The value that pruned weights will be set to
+ - `min_value`: The lowest value a weight/bias can be to be oeprated on
+ - `max_value`: The highest value a weight/bias can be to be operated on
+ - `cutoff`: number of epochs to perform PBWOs
+ - `do_weights`: perform pruning on weights
+ - `do_biases`: perform pruning on biases
+
+# NeuroPlast
+The goal of the NeuroPlast callback is to randomly re-initialize weights/biases that are effectively 0.
+
+Parameters:
+
+ - `set_value`: re-initialized weights will be set to this value, rather than a random one
+ - `min_value`: lowest value a weight/bias can be to be operated on
+ - `max_value`: highest value a weight/bias can be to be operated on
+ - `low_bound`: low bound for weight re-initialization
+ - `high_bound`: high bound for weight re-initialization
+ - `cutoff`: number of epochs to perform PBWOs
+ - `do_weights`: perform neuroplast on weights
+ - `do_biases`: perform neuroplast on biases
+
+# Usage
+KeraStroke Callbacks can be used like any other custom callback. Here's a basic example:
+
+```python
+from kerastroke import Stroke
+model.fit(X, y,
+ epochs=32,
+ callbacks=[Stroke()])
+```
+
+
+
+
+%package -n python3-kerastroke
+Summary: A suite of the generalization-improvement techniques Stroke, Pruning, and NeuroPlast
+Provides: python-kerastroke
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-kerastroke
+# KeraStroke
+
+KeraStroke is a [Python package](https://pypi.org/project/kerastroke/#description) that implements
+"Post-Back-propagation Weight Operations", or "PBWOs"; generalization-improvement techniques for Keras models in the
+form of custom Keras Callbacks. These techniques function
+similarly but have different philosophies and results. The techniques are:
+- Stroke: Re-initializaing random weight/bias values.
+- Pruning: Reducing model size by setting weight/bias values that are close to 0, to 0.
+- NeuroPlast: Re-initializing any weight/bias values that are 0 or close to 0.
+
+Stroke is modeled after seizures, which send random electrical signals throughout the brain, sometimes causing damage
+to synapses.
+
+NeuroPlast is modeled after the concept of neuroplasticity, when neurons that no longer have a primary function begin
+to rewire to improve another function. I started working on NeuroPlast after I read the work done by Blakemore and
+Cooper on horizontal/vertical line receptor neurons in the brains of cats.
+
+If you'd like to see the tests I'm performing with KeraStroke, you can view my testing repository
+[here](https://github.com/CharlesAverill/stroke-testing).
+
+KeraStroke 2.0.0 marks when I really started putting work into the project. I've made an effort to comment more,
+clean my code up, and make the package easier to understand overall without sacrificing utility.
+
+# Limitations
+KeraStroke is still in the development phase. Heavy testing has been done on
+Dense nets, but little testing has been done on CNNs and no testing has been done on RNNs. As of 2.1.0, CNNs are
+functioning properly in KeraStroke! The issue with previous versions had to do with the way the callback would retrieve
+ the weights from the models. The callbacks perform significantly better on DenseNets, but could still find use in CNNs.
+ I'm working on this, but will definitely need the help. Please see
+ [the github page](https://github.com/CharlesAverill/kerastroke/) or
+ [contact me](https://mail.google.com/mail/?view=cm&fs=1&to=charlesaverill20@gmail.com) to contribute to the project.
+
+# Stroke
+The goal of the Stroke callback is to re-initialize weights/biases that have begun to contribute to overfitting.
+
+Parameters:
+
+ - `set_value`: re-initialized weights will be set to this value, rather than a random one
+ - `low_bound`: low bound for weight re-initialization
+ - `high_bound`: high bound for weight re-initialization
+ - `volatility_ratio`: percentage of weights to be re-initialized
+ - `cutoff`: number of epochs to perform PBWOs
+ - `decay`: Every epoch, v_ratio is multiplied by this number. decay can be greater than 1.0,
+ but v_ratio will never exceed 1.0
+ - `do_weights`: perform stroke on weights
+ - `do_biases`: perform stroke on biases
+
+# Pruning
+The goal of the Pruning callback is to nullify weights/biases that are effectively 0.
+
+Parameters:
+
+ - `set_value`: The value that pruned weights will be set to
+ - `min_value`: The lowest value a weight/bias can be to be oeprated on
+ - `max_value`: The highest value a weight/bias can be to be operated on
+ - `cutoff`: number of epochs to perform PBWOs
+ - `do_weights`: perform pruning on weights
+ - `do_biases`: perform pruning on biases
+
+# NeuroPlast
+The goal of the NeuroPlast callback is to randomly re-initialize weights/biases that are effectively 0.
+
+Parameters:
+
+ - `set_value`: re-initialized weights will be set to this value, rather than a random one
+ - `min_value`: lowest value a weight/bias can be to be operated on
+ - `max_value`: highest value a weight/bias can be to be operated on
+ - `low_bound`: low bound for weight re-initialization
+ - `high_bound`: high bound for weight re-initialization
+ - `cutoff`: number of epochs to perform PBWOs
+ - `do_weights`: perform neuroplast on weights
+ - `do_biases`: perform neuroplast on biases
+
+# Usage
+KeraStroke Callbacks can be used like any other custom callback. Here's a basic example:
+
+```python
+from kerastroke import Stroke
+model.fit(X, y,
+ epochs=32,
+ callbacks=[Stroke()])
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for kerastroke
+Provides: python3-kerastroke-doc
+%description help
+# KeraStroke
+
+KeraStroke is a [Python package](https://pypi.org/project/kerastroke/#description) that implements
+"Post-Back-propagation Weight Operations", or "PBWOs"; generalization-improvement techniques for Keras models in the
+form of custom Keras Callbacks. These techniques function
+similarly but have different philosophies and results. The techniques are:
+- Stroke: Re-initializaing random weight/bias values.
+- Pruning: Reducing model size by setting weight/bias values that are close to 0, to 0.
+- NeuroPlast: Re-initializing any weight/bias values that are 0 or close to 0.
+
+Stroke is modeled after seizures, which send random electrical signals throughout the brain, sometimes causing damage
+to synapses.
+
+NeuroPlast is modeled after the concept of neuroplasticity, when neurons that no longer have a primary function begin
+to rewire to improve another function. I started working on NeuroPlast after I read the work done by Blakemore and
+Cooper on horizontal/vertical line receptor neurons in the brains of cats.
+
+If you'd like to see the tests I'm performing with KeraStroke, you can view my testing repository
+[here](https://github.com/CharlesAverill/stroke-testing).
+
+KeraStroke 2.0.0 marks when I really started putting work into the project. I've made an effort to comment more,
+clean my code up, and make the package easier to understand overall without sacrificing utility.
+
+# Limitations
+KeraStroke is still in the development phase. Heavy testing has been done on
+Dense nets, but little testing has been done on CNNs and no testing has been done on RNNs. As of 2.1.0, CNNs are
+functioning properly in KeraStroke! The issue with previous versions had to do with the way the callback would retrieve
+ the weights from the models. The callbacks perform significantly better on DenseNets, but could still find use in CNNs.
+ I'm working on this, but will definitely need the help. Please see
+ [the github page](https://github.com/CharlesAverill/kerastroke/) or
+ [contact me](https://mail.google.com/mail/?view=cm&fs=1&to=charlesaverill20@gmail.com) to contribute to the project.
+
+# Stroke
+The goal of the Stroke callback is to re-initialize weights/biases that have begun to contribute to overfitting.
+
+Parameters:
+
+ - `set_value`: re-initialized weights will be set to this value, rather than a random one
+ - `low_bound`: low bound for weight re-initialization
+ - `high_bound`: high bound for weight re-initialization
+ - `volatility_ratio`: percentage of weights to be re-initialized
+ - `cutoff`: number of epochs to perform PBWOs
+ - `decay`: Every epoch, v_ratio is multiplied by this number. decay can be greater than 1.0,
+ but v_ratio will never exceed 1.0
+ - `do_weights`: perform stroke on weights
+ - `do_biases`: perform stroke on biases
+
+# Pruning
+The goal of the Pruning callback is to nullify weights/biases that are effectively 0.
+
+Parameters:
+
+ - `set_value`: The value that pruned weights will be set to
+ - `min_value`: The lowest value a weight/bias can be to be oeprated on
+ - `max_value`: The highest value a weight/bias can be to be operated on
+ - `cutoff`: number of epochs to perform PBWOs
+ - `do_weights`: perform pruning on weights
+ - `do_biases`: perform pruning on biases
+
+# NeuroPlast
+The goal of the NeuroPlast callback is to randomly re-initialize weights/biases that are effectively 0.
+
+Parameters:
+
+ - `set_value`: re-initialized weights will be set to this value, rather than a random one
+ - `min_value`: lowest value a weight/bias can be to be operated on
+ - `max_value`: highest value a weight/bias can be to be operated on
+ - `low_bound`: low bound for weight re-initialization
+ - `high_bound`: high bound for weight re-initialization
+ - `cutoff`: number of epochs to perform PBWOs
+ - `do_weights`: perform neuroplast on weights
+ - `do_biases`: perform neuroplast on biases
+
+# Usage
+KeraStroke Callbacks can be used like any other custom callback. Here's a basic example:
+
+```python
+from kerastroke import Stroke
+model.fit(X, y,
+ epochs=32,
+ callbacks=[Stroke()])
+```
+
+
+
+
+%prep
+%autosetup -n kerastroke-2.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-kerastroke -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1-1
+- Package Spec generated