summaryrefslogtreecommitdiff
path: root/python-label-studio.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-label-studio.spec')
-rw-r--r--python-label-studio.spec13
1 files changed, 8 insertions, 5 deletions
diff --git a/python-label-studio.spec b/python-label-studio.spec
index baf6559..0f7880e 100644
--- a/python-label-studio.spec
+++ b/python-label-studio.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-label-studio
-Version: 1.7.2
+Version: 1.7.3
Release: 1
Summary: Label Studio annotation tool
License: Apache Software License
URL: https://github.com/heartexlabs/label-studio
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d2/19/2106b6e98db7f23d81fe8f65cae14bb4273908592fd5239286644259cc54/label-studio-1.7.2.tar.gz
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/33/2b/ff76b68ea7bc4abd6557966e896e817a6d14ba0f5f31ddc8006335bf3172/label-studio-1.7.3.tar.gz
BuildArch: noarch
Requires: python3-wheel
@@ -54,7 +54,7 @@ Requires: python3-numpy
Requires: python3-ordered-set
Requires: python3-pandas
Requires: python3-protobuf
-Requires: python3-psycopg2
+Requires: python3-psycopg2-binary
Requires: python3-pydantic
Requires: python3-dateutil
Requires: python3-pytz
@@ -169,6 +169,7 @@ You can run the latest Label Studio version locally without installing the packa
pip install -e .
# Run database migrations
python label_studio/manage.py migrate
+python label_studio/manage.py collectstatic
# Start the server in development mode at http://localhost:8080
python label_studio/manage.py runserver
```
@@ -410,6 +411,7 @@ You can run the latest Label Studio version locally without installing the packa
pip install -e .
# Run database migrations
python label_studio/manage.py migrate
+python label_studio/manage.py collectstatic
# Start the server in development mode at http://localhost:8080
python label_studio/manage.py runserver
```
@@ -648,6 +650,7 @@ You can run the latest Label Studio version locally without installing the packa
pip install -e .
# Run database migrations
python label_studio/manage.py migrate
+python label_studio/manage.py collectstatic
# Start the server in development mode at http://localhost:8080
python label_studio/manage.py runserver
```
@@ -787,7 +790,7 @@ This software is licensed under the [Apache 2.0 LICENSE](/LICENSE) © [Heartex](
%prep
-%autosetup -n label-studio-1.7.2
+%autosetup -n label-studio-1.7.3
%build
%py3_build
@@ -827,5 +830,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.2-1
+* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.3-1
- Package Spec generated