summaryrefslogtreecommitdiff
path: root/python-labmath.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 09:40:31 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 09:40:31 +0000
commit2a629a8c76d2b360ecffc31f1b98208b0e266c0d (patch)
treebc772c28871aeeb7fe53d37d3e97e0655aa62b00 /python-labmath.spec
parenteac64365a70e3d1e1435f9a8e020dd4ac1407574 (diff)
automatic import of python-labmath
Diffstat (limited to 'python-labmath.spec')
-rw-r--r--python-labmath.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-labmath.spec b/python-labmath.spec
new file mode 100644
index 0000000..fdd3b35
--- /dev/null
+++ b/python-labmath.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-labmath
+Version: 2.2.0
+Release: 1
+Summary: Module for basic math in the general vicinity of computational number theory
+License: MIT License
+URL: https://pypi.org/manage/project/labmath
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/02/93aaa577f88aae2c4d4b25bfd482928b6bf601bdcb9272fd3a5d959e4104/labmath-2.2.0.tar.gz
+BuildArch: noarch
+
+
+%description
+This is a module for basic math in the general vicinity of computational number theory. It includes functions associated with primality testing, integer factoring, prime counting, linear recurrences, modular square roots, generalized Pell equations, the classic arithmetical functions, continued fractions, partitions, Størmer's theorem, smooth numbers, and Dirichlet convolution. Integer arithmetic is used wherever feasible.
+
+%package -n python3-labmath
+Summary: Module for basic math in the general vicinity of computational number theory
+Provides: python-labmath
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-labmath
+This is a module for basic math in the general vicinity of computational number theory. It includes functions associated with primality testing, integer factoring, prime counting, linear recurrences, modular square roots, generalized Pell equations, the classic arithmetical functions, continued fractions, partitions, Størmer's theorem, smooth numbers, and Dirichlet convolution. Integer arithmetic is used wherever feasible.
+
+%package help
+Summary: Development documents and examples for labmath
+Provides: python3-labmath-doc
+%description help
+This is a module for basic math in the general vicinity of computational number theory. It includes functions associated with primality testing, integer factoring, prime counting, linear recurrences, modular square roots, generalized Pell equations, the classic arithmetical functions, continued fractions, partitions, Størmer's theorem, smooth numbers, and Dirichlet convolution. Integer arithmetic is used wherever feasible.
+
+%prep
+%autosetup -n labmath-2.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-labmath -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.0-1
+- Package Spec generated