summaryrefslogtreecommitdiff
path: root/python-levo-commons.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-levo-commons.spec')
-rw-r--r--python-levo-commons.spec123
1 files changed, 123 insertions, 0 deletions
diff --git a/python-levo-commons.spec b/python-levo-commons.spec
new file mode 100644
index 0000000..3bd3fd9
--- /dev/null
+++ b/python-levo-commons.spec
@@ -0,0 +1,123 @@
+%global _empty_manifest_terminate_build 0
+Name: python-levo-commons
+Version: 0.1.41
+Release: 1
+Summary: Common code between Levo CLI and test plans.
+License: MIT License
+URL: https://github.com/levoai/levo-commons
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/56/43/656136ea82b917638688d7ca5d86d6d69ca7ebeece15d899adafcbebe703/levo_commons-0.1.41.tar.gz
+BuildArch: noarch
+
+Requires: python3-attrs
+Requires: python3-curlify
+Requires: python3-grpcio
+Requires: python3-requests
+Requires: python3-pytest
+Requires: python3-hypothesis
+
+%description
+# levo-commons
+Common code between Levo's CLI and test plans
+
+# Running the checks and tests locally
+
+```bash
+# Pre-commit checks
+pip install pre-commit
+SKIP=pylint,mypy pre-commit run --all-files
+pre-commit run mypy --all-files
+
+# Unit tests
+pip install tox
+tox -e py
+```
+
+
+%package -n python3-levo-commons
+Summary: Common code between Levo CLI and test plans.
+Provides: python-levo-commons
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-levo-commons
+# levo-commons
+Common code between Levo's CLI and test plans
+
+# Running the checks and tests locally
+
+```bash
+# Pre-commit checks
+pip install pre-commit
+SKIP=pylint,mypy pre-commit run --all-files
+pre-commit run mypy --all-files
+
+# Unit tests
+pip install tox
+tox -e py
+```
+
+
+%package help
+Summary: Development documents and examples for levo-commons
+Provides: python3-levo-commons-doc
+%description help
+# levo-commons
+Common code between Levo's CLI and test plans
+
+# Running the checks and tests locally
+
+```bash
+# Pre-commit checks
+pip install pre-commit
+SKIP=pylint,mypy pre-commit run --all-files
+pre-commit run mypy --all-files
+
+# Unit tests
+pip install tox
+tox -e py
+```
+
+
+%prep
+%autosetup -n levo-commons-0.1.41
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-levo-commons -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.41-1
+- Package Spec generated