summaryrefslogtreecommitdiff
path: root/python-lib-registry.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-lib-registry.spec')
-rw-r--r--python-lib-registry.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-lib-registry.spec b/python-lib-registry.spec
new file mode 100644
index 0000000..d27efdb
--- /dev/null
+++ b/python-lib-registry.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-lib-registry
+Version: 2.0.7
+Release: 1
+Summary: a more pythonic way to access the windows registry as winreg
+License: MIT License
+URL: https://github.com/bitranox/lib_registry
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0f/42/9bdc28b31866b7d157d3bfec911cf7675ad104a073d0a05b0f1b8a9ba833/lib_registry-2.0.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-click
+Requires: python3-cli-exit-tools
+Requires: python3-fake-winreg
+
+%description
+Version v2.0.7 as of 2020-10-10 see `Changelog`_
+|travis_build| |license| |jupyter| |pypi|
+|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
+a more pythonic way to access the windows registry as winreg
+
+%package -n python3-lib-registry
+Summary: a more pythonic way to access the windows registry as winreg
+Provides: python-lib-registry
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-lib-registry
+Version v2.0.7 as of 2020-10-10 see `Changelog`_
+|travis_build| |license| |jupyter| |pypi|
+|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
+a more pythonic way to access the windows registry as winreg
+
+%package help
+Summary: Development documents and examples for lib-registry
+Provides: python3-lib-registry-doc
+%description help
+Version v2.0.7 as of 2020-10-10 see `Changelog`_
+|travis_build| |license| |jupyter| |pypi|
+|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
+a more pythonic way to access the windows registry as winreg
+
+%prep
+%autosetup -n lib-registry-2.0.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-lib-registry -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.7-1
+- Package Spec generated