summaryrefslogtreecommitdiff
path: root/python-libwapiti.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-libwapiti.spec')
-rw-r--r--python-libwapiti.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-libwapiti.spec b/python-libwapiti.spec
new file mode 100644
index 0000000..c638e5d
--- /dev/null
+++ b/python-libwapiti.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-libwapiti
+Version: 0.2.1
+Release: 1
+Summary: Python bindings for libwapiti
+License: UNKNOWN
+URL: UNKNOWN
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bc/0f/1c9b49bb49821b5856a64ea6fac8d96a619b9f291d1f06999ea98a32c89c/libwapiti-0.2.1.tar.gz
+BuildArch: noarch
+
+
+%description
+python-wapiti is a python wrapper for wapiti (http://wapiti.limsi.fr), a very nice sequence labeling
+tool with support for maxent models, maximum entropy Markov models and linear-chain CRF.
+
+
+%package -n python3-libwapiti
+Summary: Python bindings for libwapiti
+Provides: python-libwapiti
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-libwapiti
+python-wapiti is a python wrapper for wapiti (http://wapiti.limsi.fr), a very nice sequence labeling
+tool with support for maxent models, maximum entropy Markov models and linear-chain CRF.
+
+
+%package help
+Summary: Development documents and examples for libwapiti
+Provides: python3-libwapiti-doc
+%description help
+python-wapiti is a python wrapper for wapiti (http://wapiti.limsi.fr), a very nice sequence labeling
+tool with support for maxent models, maximum entropy Markov models and linear-chain CRF.
+
+
+%prep
+%autosetup -n libwapiti-0.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-libwapiti -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
+- Package Spec generated