summaryrefslogtreecommitdiff
path: root/python-lightkurve.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-lightkurve.spec')
-rw-r--r--python-lightkurve.spec119
1 files changed, 119 insertions, 0 deletions
diff --git a/python-lightkurve.spec b/python-lightkurve.spec
new file mode 100644
index 0000000..bfe6091
--- /dev/null
+++ b/python-lightkurve.spec
@@ -0,0 +1,119 @@
+%global _empty_manifest_terminate_build 0
+Name: python-lightkurve
+Version: 2.4.0
+Release: 1
+Summary: A friendly package for Kepler & TESS time series analysis in Python.
+License: MIT
+URL: https://docs.lightkurve.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/38/63/314ee836ca331f7c8e468cce7f70d91213a068b5181486d7f631b5c5174a/lightkurve-2.4.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-astropy
+Requires: python3-scipy
+Requires: python3-matplotlib
+Requires: python3-astroquery
+Requires: python3-oktopus
+Requires: python3-beautifulsoup4
+Requires: python3-requests
+Requires: python3-urllib3
+Requires: python3-tqdm
+Requires: python3-pandas
+Requires: python3-uncertainties
+Requires: python3-patsy
+Requires: python3-fbpca
+Requires: python3-bokeh
+Requires: python3-memoization
+Requires: python3-scikit-learn
+
+%description
+**A friendly package for Kepler & TESS time series analysis in Python.**
+**Documentation: https://docs.lightkurve.org**
+|test-badge| |conda-badge| |pypi-badge| |pypi-downloads| |doi-badge| |astropy-badge|
+**Lightkurve** is a community-developed, open-source Python package which offers a beautiful and user-friendly way
+to analyze astronomical flux time series data,
+in particular the pixels and lightcurves obtained by
+**NASA's Kepler and TESS exoplanet missions**.
+This package aims to lower the barrier for students, astronomers,
+and citizen scientists interested in analyzing Kepler and TESS space telescope data.
+It does this by providing **high-quality building blocks and tutorials**
+which enable both hand-tailored data analyses and advanced automated pipelines.
+
+%package -n python3-lightkurve
+Summary: A friendly package for Kepler & TESS time series analysis in Python.
+Provides: python-lightkurve
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-lightkurve
+**A friendly package for Kepler & TESS time series analysis in Python.**
+**Documentation: https://docs.lightkurve.org**
+|test-badge| |conda-badge| |pypi-badge| |pypi-downloads| |doi-badge| |astropy-badge|
+**Lightkurve** is a community-developed, open-source Python package which offers a beautiful and user-friendly way
+to analyze astronomical flux time series data,
+in particular the pixels and lightcurves obtained by
+**NASA's Kepler and TESS exoplanet missions**.
+This package aims to lower the barrier for students, astronomers,
+and citizen scientists interested in analyzing Kepler and TESS space telescope data.
+It does this by providing **high-quality building blocks and tutorials**
+which enable both hand-tailored data analyses and advanced automated pipelines.
+
+%package help
+Summary: Development documents and examples for lightkurve
+Provides: python3-lightkurve-doc
+%description help
+**A friendly package for Kepler & TESS time series analysis in Python.**
+**Documentation: https://docs.lightkurve.org**
+|test-badge| |conda-badge| |pypi-badge| |pypi-downloads| |doi-badge| |astropy-badge|
+**Lightkurve** is a community-developed, open-source Python package which offers a beautiful and user-friendly way
+to analyze astronomical flux time series data,
+in particular the pixels and lightcurves obtained by
+**NASA's Kepler and TESS exoplanet missions**.
+This package aims to lower the barrier for students, astronomers,
+and citizen scientists interested in analyzing Kepler and TESS space telescope data.
+It does this by providing **high-quality building blocks and tutorials**
+which enable both hand-tailored data analyses and advanced automated pipelines.
+
+%prep
+%autosetup -n lightkurve-2.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-lightkurve -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.0-1
+- Package Spec generated