summaryrefslogtreecommitdiff
path: root/python-litncov.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 06:34:07 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 06:34:07 +0000
commitd361675aeb9f2ef0be814fae22d37db7a0b7974a (patch)
tree34a2dbd83c239902e1f286c0339fc50dbabf4c48 /python-litncov.spec
parentb5289ab9b580ef21fd5a0424a84b065a57fb5ca2 (diff)
automatic import of python-litncovopeneuler20.03
Diffstat (limited to 'python-litncov.spec')
-rw-r--r--python-litncov.spec630
1 files changed, 630 insertions, 0 deletions
diff --git a/python-litncov.spec b/python-litncov.spec
new file mode 100644
index 0000000..80fcddd
--- /dev/null
+++ b/python-litncov.spec
@@ -0,0 +1,630 @@
+%global _empty_manifest_terminate_build 0
+Name: python-litncov
+Version: 2.2.1
+Release: 1
+Summary: A ncov report library and tool for LIT(Luoyang Institute of Science and Technology)
+License: MIT
+URL: http://github.com/icepie/lit-ncov-report
+Source0: https://mirrors.aliyun.com/pypi/web/packages/01/ef/60c5fd2d556711867a309faa2ceabb9d097bea63b23fef12eee7ac9103cb/litncov-2.2.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-rich
+Requires: python3-requests
+Requires: python3-pytz
+
+%description
+# lit-ncov-report
+洛阳理工学院 "健康状况管控平台" 的一个非官方`Python封装库`兼`CLI工具`与`拓展实现`
+
+[![pypi version](https://img.shields.io/pypi/v/litncov)](https://pypi.org/project/litncov/)
+[![pypi downloads per month](https://img.shields.io/pypi/dm/litncov)](https://pypi.org/project/litncov/)
+[![Docker Pulls](https://img.shields.io/docker/pulls/icepie/litncov.svg)](https://hub.docker.com/r/icepie/litncov/)
+[![License: MIT](https://img.shields.io/badge/License-MIT-brightgreen.svg)](https://opensource.org/licenses/MIT)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+
+[![QQ Group](https://img.shields.io/badge/QQ%20Group-647027400-red.svg)](https://jq.qq.com/?_wv=1027&k=lz0XyN86)
+[![TG Group](https://img.shields.io/badge/TG%20Group-lit_edu-blue.svg)](https://t.me/lit_edu)
+
+> 如需旧版请前往 [v1](https://github.com/icepie/lit-ncov-report/tree/v1)
+
+> Serverless(如云函数)请前往 [scf](https://github.com/icepie/lit-ncov-report/tree/scf)
+
+## 安装
+
+### Python
+
+```bash
+# Python3.6+ with pip
+pip install litncov --upgrade
+```
+
+### Docker
+
+```bash
+docker run -it --rm icepie/litncov
+```
+
+## 封装库
+
+### 范例
+
+```python
+# 导入模块
+from litncov.user import litUesr
+
+# 新建实例
+testme = litUesr("username", "password")
+
+# 判断是否登陆成功
+if testme.is_logged():
+ # 打印用户信息
+ print(testme.info)
+ # 打印上次上报信息
+ print(testme.get_last_record())
+ # 查询 2021-01-04 至今的上报信息
+ print(testme.query_record('2021-01-04'))
+ # 查询 2021-01-04 至 2021-01-18 的上报信息
+ print(testme.query_record('2021-01-04', '2021-01-18'))
+ # 打印学生学籍信息
+ print(testme.get_instructor())
+ # 打印用户家庭信息
+ print(testme.get_familys())
+ # 打印用户外出信息
+ print(testme.get_trips())
+ # 打印疫情严重地区
+ print(testme.get_important_city())
+ # 判断今天是否上报过
+ if not testme.is_record_today():
+ # 进行当日第一次体温上报
+ ## 模式:使用上一次上报信息, 次数: 只上报第一次
+ print(testme.first_record(mode='last', rtimes=1))
+ # 判断今天是否第二次上报过
+ if not testme.is_record_today(2):
+ # 进行当日第二次体温上报
+ ## 模式:手动填入, 温度: 36.6 摄氏度
+ print(testme.second_record(mode='manual', temperature=36.6))
+ # 判断今天是否第三次上报过
+ if not testme.is_record_today(rtime=3):
+ # 进行当日第三次体温上报
+ ## 模式:随机生成正常体温(36.0~37.2 摄氏度)
+ print(testme.third_record(mode='random'))
+```
+
+## CLI工具
+
+### 上报功能
+
+#### 例子
+
+- 使用上一条上报记录进行今天三次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -a
+# 不带 -a 参数则只进行今天第一次上报
+```
+
+- 使用随机温度进行今天第二次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -r 2 -m random
+```
+
+- 手动输入温度进行今天第三次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -r 3 -t 36.7
+```
+
+#### 帮助
+
+```
+$ litncov report -h
+usage: litncov report [-h] [-a] [-f] [-r RTIME] [-m MODE] [-t TEMP]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -a, --all do the all report tasks today
+ -f, --force forcely report
+ -r RTIME, --rtime RTIME
+ the report time {1,2,3}
+ -m MODE, --mode MODE the report mode {last,random,manual}, default last
+ -t TEMP, --temp TEMP the body temperature (float), only use in manual
+```
+
+### 查询用户信息
+
+#### 例子
+
+- 主要个人信息
+
+```bash
+$ litncov -u USERNAME -p USERNAME info --user
+```
+
+- 外出信息
+
+```bash
+$ litncov -u USERNAME -p USERNAME info --trip
+```
+
+- 上次上报记录
+
+```bash
+$ litncov -u USERNAME -p USERNAME info -l
+```
+
+#### 帮助
+
+```
+$ litncov info -h
+usage: litncov info [-h] [-u] [-l] [-f] [-i] [-t]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -u, --user the user main info
+ -l, --last_record the user last record info
+ -f, --family the user family info
+ -i, --instructor the user instructor info
+ -t, --tirp the user tirp info
+
+```
+
+### 查询上报记录
+
+#### 例子
+- 查询某日至今
+
+```bash
+$ litncov -u USERNAME -p PASSWORD query -s 2020-01-01
+```
+
+- 查询某日至某日
+
+```bash
+$ litncov -u USERNAME -p PASSWORD query -s 2020-01-01 -e 2020-01-15
+```
+
+#### 帮助
+
+```
+usage: litncov query [-h] -s START_TIME [-e END_TIME]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -s START_TIME, --start_time START_TIME
+ the start time of the report history (Year-Month-Day)
+ -e END_TIME, --end_time END_TIME
+ the end time of the report history, default Today (Year-Month-Day)
+```
+
+
+
+
+%package -n python3-litncov
+Summary: A ncov report library and tool for LIT(Luoyang Institute of Science and Technology)
+Provides: python-litncov
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-litncov
+# lit-ncov-report
+洛阳理工学院 "健康状况管控平台" 的一个非官方`Python封装库`兼`CLI工具`与`拓展实现`
+
+[![pypi version](https://img.shields.io/pypi/v/litncov)](https://pypi.org/project/litncov/)
+[![pypi downloads per month](https://img.shields.io/pypi/dm/litncov)](https://pypi.org/project/litncov/)
+[![Docker Pulls](https://img.shields.io/docker/pulls/icepie/litncov.svg)](https://hub.docker.com/r/icepie/litncov/)
+[![License: MIT](https://img.shields.io/badge/License-MIT-brightgreen.svg)](https://opensource.org/licenses/MIT)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+
+[![QQ Group](https://img.shields.io/badge/QQ%20Group-647027400-red.svg)](https://jq.qq.com/?_wv=1027&k=lz0XyN86)
+[![TG Group](https://img.shields.io/badge/TG%20Group-lit_edu-blue.svg)](https://t.me/lit_edu)
+
+> 如需旧版请前往 [v1](https://github.com/icepie/lit-ncov-report/tree/v1)
+
+> Serverless(如云函数)请前往 [scf](https://github.com/icepie/lit-ncov-report/tree/scf)
+
+## 安装
+
+### Python
+
+```bash
+# Python3.6+ with pip
+pip install litncov --upgrade
+```
+
+### Docker
+
+```bash
+docker run -it --rm icepie/litncov
+```
+
+## 封装库
+
+### 范例
+
+```python
+# 导入模块
+from litncov.user import litUesr
+
+# 新建实例
+testme = litUesr("username", "password")
+
+# 判断是否登陆成功
+if testme.is_logged():
+ # 打印用户信息
+ print(testme.info)
+ # 打印上次上报信息
+ print(testme.get_last_record())
+ # 查询 2021-01-04 至今的上报信息
+ print(testme.query_record('2021-01-04'))
+ # 查询 2021-01-04 至 2021-01-18 的上报信息
+ print(testme.query_record('2021-01-04', '2021-01-18'))
+ # 打印学生学籍信息
+ print(testme.get_instructor())
+ # 打印用户家庭信息
+ print(testme.get_familys())
+ # 打印用户外出信息
+ print(testme.get_trips())
+ # 打印疫情严重地区
+ print(testme.get_important_city())
+ # 判断今天是否上报过
+ if not testme.is_record_today():
+ # 进行当日第一次体温上报
+ ## 模式:使用上一次上报信息, 次数: 只上报第一次
+ print(testme.first_record(mode='last', rtimes=1))
+ # 判断今天是否第二次上报过
+ if not testme.is_record_today(2):
+ # 进行当日第二次体温上报
+ ## 模式:手动填入, 温度: 36.6 摄氏度
+ print(testme.second_record(mode='manual', temperature=36.6))
+ # 判断今天是否第三次上报过
+ if not testme.is_record_today(rtime=3):
+ # 进行当日第三次体温上报
+ ## 模式:随机生成正常体温(36.0~37.2 摄氏度)
+ print(testme.third_record(mode='random'))
+```
+
+## CLI工具
+
+### 上报功能
+
+#### 例子
+
+- 使用上一条上报记录进行今天三次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -a
+# 不带 -a 参数则只进行今天第一次上报
+```
+
+- 使用随机温度进行今天第二次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -r 2 -m random
+```
+
+- 手动输入温度进行今天第三次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -r 3 -t 36.7
+```
+
+#### 帮助
+
+```
+$ litncov report -h
+usage: litncov report [-h] [-a] [-f] [-r RTIME] [-m MODE] [-t TEMP]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -a, --all do the all report tasks today
+ -f, --force forcely report
+ -r RTIME, --rtime RTIME
+ the report time {1,2,3}
+ -m MODE, --mode MODE the report mode {last,random,manual}, default last
+ -t TEMP, --temp TEMP the body temperature (float), only use in manual
+```
+
+### 查询用户信息
+
+#### 例子
+
+- 主要个人信息
+
+```bash
+$ litncov -u USERNAME -p USERNAME info --user
+```
+
+- 外出信息
+
+```bash
+$ litncov -u USERNAME -p USERNAME info --trip
+```
+
+- 上次上报记录
+
+```bash
+$ litncov -u USERNAME -p USERNAME info -l
+```
+
+#### 帮助
+
+```
+$ litncov info -h
+usage: litncov info [-h] [-u] [-l] [-f] [-i] [-t]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -u, --user the user main info
+ -l, --last_record the user last record info
+ -f, --family the user family info
+ -i, --instructor the user instructor info
+ -t, --tirp the user tirp info
+
+```
+
+### 查询上报记录
+
+#### 例子
+- 查询某日至今
+
+```bash
+$ litncov -u USERNAME -p PASSWORD query -s 2020-01-01
+```
+
+- 查询某日至某日
+
+```bash
+$ litncov -u USERNAME -p PASSWORD query -s 2020-01-01 -e 2020-01-15
+```
+
+#### 帮助
+
+```
+usage: litncov query [-h] -s START_TIME [-e END_TIME]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -s START_TIME, --start_time START_TIME
+ the start time of the report history (Year-Month-Day)
+ -e END_TIME, --end_time END_TIME
+ the end time of the report history, default Today (Year-Month-Day)
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for litncov
+Provides: python3-litncov-doc
+%description help
+# lit-ncov-report
+洛阳理工学院 "健康状况管控平台" 的一个非官方`Python封装库`兼`CLI工具`与`拓展实现`
+
+[![pypi version](https://img.shields.io/pypi/v/litncov)](https://pypi.org/project/litncov/)
+[![pypi downloads per month](https://img.shields.io/pypi/dm/litncov)](https://pypi.org/project/litncov/)
+[![Docker Pulls](https://img.shields.io/docker/pulls/icepie/litncov.svg)](https://hub.docker.com/r/icepie/litncov/)
+[![License: MIT](https://img.shields.io/badge/License-MIT-brightgreen.svg)](https://opensource.org/licenses/MIT)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+
+[![QQ Group](https://img.shields.io/badge/QQ%20Group-647027400-red.svg)](https://jq.qq.com/?_wv=1027&k=lz0XyN86)
+[![TG Group](https://img.shields.io/badge/TG%20Group-lit_edu-blue.svg)](https://t.me/lit_edu)
+
+> 如需旧版请前往 [v1](https://github.com/icepie/lit-ncov-report/tree/v1)
+
+> Serverless(如云函数)请前往 [scf](https://github.com/icepie/lit-ncov-report/tree/scf)
+
+## 安装
+
+### Python
+
+```bash
+# Python3.6+ with pip
+pip install litncov --upgrade
+```
+
+### Docker
+
+```bash
+docker run -it --rm icepie/litncov
+```
+
+## 封装库
+
+### 范例
+
+```python
+# 导入模块
+from litncov.user import litUesr
+
+# 新建实例
+testme = litUesr("username", "password")
+
+# 判断是否登陆成功
+if testme.is_logged():
+ # 打印用户信息
+ print(testme.info)
+ # 打印上次上报信息
+ print(testme.get_last_record())
+ # 查询 2021-01-04 至今的上报信息
+ print(testme.query_record('2021-01-04'))
+ # 查询 2021-01-04 至 2021-01-18 的上报信息
+ print(testme.query_record('2021-01-04', '2021-01-18'))
+ # 打印学生学籍信息
+ print(testme.get_instructor())
+ # 打印用户家庭信息
+ print(testme.get_familys())
+ # 打印用户外出信息
+ print(testme.get_trips())
+ # 打印疫情严重地区
+ print(testme.get_important_city())
+ # 判断今天是否上报过
+ if not testme.is_record_today():
+ # 进行当日第一次体温上报
+ ## 模式:使用上一次上报信息, 次数: 只上报第一次
+ print(testme.first_record(mode='last', rtimes=1))
+ # 判断今天是否第二次上报过
+ if not testme.is_record_today(2):
+ # 进行当日第二次体温上报
+ ## 模式:手动填入, 温度: 36.6 摄氏度
+ print(testme.second_record(mode='manual', temperature=36.6))
+ # 判断今天是否第三次上报过
+ if not testme.is_record_today(rtime=3):
+ # 进行当日第三次体温上报
+ ## 模式:随机生成正常体温(36.0~37.2 摄氏度)
+ print(testme.third_record(mode='random'))
+```
+
+## CLI工具
+
+### 上报功能
+
+#### 例子
+
+- 使用上一条上报记录进行今天三次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -a
+# 不带 -a 参数则只进行今天第一次上报
+```
+
+- 使用随机温度进行今天第二次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -r 2 -m random
+```
+
+- 手动输入温度进行今天第三次上报
+
+```bash
+$ litncov -u USERNAME -p PASSWORD report -r 3 -t 36.7
+```
+
+#### 帮助
+
+```
+$ litncov report -h
+usage: litncov report [-h] [-a] [-f] [-r RTIME] [-m MODE] [-t TEMP]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -a, --all do the all report tasks today
+ -f, --force forcely report
+ -r RTIME, --rtime RTIME
+ the report time {1,2,3}
+ -m MODE, --mode MODE the report mode {last,random,manual}, default last
+ -t TEMP, --temp TEMP the body temperature (float), only use in manual
+```
+
+### 查询用户信息
+
+#### 例子
+
+- 主要个人信息
+
+```bash
+$ litncov -u USERNAME -p USERNAME info --user
+```
+
+- 外出信息
+
+```bash
+$ litncov -u USERNAME -p USERNAME info --trip
+```
+
+- 上次上报记录
+
+```bash
+$ litncov -u USERNAME -p USERNAME info -l
+```
+
+#### 帮助
+
+```
+$ litncov info -h
+usage: litncov info [-h] [-u] [-l] [-f] [-i] [-t]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -u, --user the user main info
+ -l, --last_record the user last record info
+ -f, --family the user family info
+ -i, --instructor the user instructor info
+ -t, --tirp the user tirp info
+
+```
+
+### 查询上报记录
+
+#### 例子
+- 查询某日至今
+
+```bash
+$ litncov -u USERNAME -p PASSWORD query -s 2020-01-01
+```
+
+- 查询某日至某日
+
+```bash
+$ litncov -u USERNAME -p PASSWORD query -s 2020-01-01 -e 2020-01-15
+```
+
+#### 帮助
+
+```
+usage: litncov query [-h] -s START_TIME [-e END_TIME]
+
+optional arguments:
+ -h, --help show this help message and exit
+ -s START_TIME, --start_time START_TIME
+ the start time of the report history (Year-Month-Day)
+ -e END_TIME, --end_time END_TIME
+ the end time of the report history, default Today (Year-Month-Day)
+```
+
+
+
+
+%prep
+%autosetup -n litncov-2.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-litncov -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.1-1
+- Package Spec generated