summaryrefslogtreecommitdiff
path: root/python-logilab-constraint.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-logilab-constraint.spec')
-rw-r--r--python-logilab-constraint.spec138
1 files changed, 138 insertions, 0 deletions
diff --git a/python-logilab-constraint.spec b/python-logilab-constraint.spec
new file mode 100644
index 0000000..b548b7d
--- /dev/null
+++ b/python-logilab-constraint.spec
@@ -0,0 +1,138 @@
+%global _empty_manifest_terminate_build 0
+Name: python-logilab-constraint
+Version: 0.6.2
+Release: 1
+Summary: constraints satisfaction solver in Python
+License: LGPL
+URL: http://www.logilab.org/projects/logilab-constraint
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/75/97/486eeb29797953c0fd27e8881efb3959cf3a0c4c48c9cd20e10047156d60/logilab-constraint-0.6.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-setuptools
+Requires: python3-logilab-common
+Requires: python3-six
+
+%description
+This package implements an extensible constraint satisfaction problem
+solver written in pure Python, using constraint propagation algorithms.
+The logilab.constraint module provides finite domains with arbitrary
+values, finite interval domains, and constraints which can be applied
+to variables linked to these domains.
+
+It requires python 2.6 or later to work, and is released under the GNU
+Lesser General Public License.
+
+The documentation is in the doc/ directory. Examples are in the
+examples/ directory.
+
+Discussion about constraint should take place on the python-projects
+mailing list. Information on subscription and mailing list archives can
+be accessed at
+https://lists.logilab.org/mailman/listinfo/python-projects/
+
+Your feedback is very valuable to us. Please share your experience with
+other users of the package on the mailing list.
+
+
+
+
+%package -n python3-logilab-constraint
+Summary: constraints satisfaction solver in Python
+Provides: python-logilab-constraint
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-logilab-constraint
+This package implements an extensible constraint satisfaction problem
+solver written in pure Python, using constraint propagation algorithms.
+The logilab.constraint module provides finite domains with arbitrary
+values, finite interval domains, and constraints which can be applied
+to variables linked to these domains.
+
+It requires python 2.6 or later to work, and is released under the GNU
+Lesser General Public License.
+
+The documentation is in the doc/ directory. Examples are in the
+examples/ directory.
+
+Discussion about constraint should take place on the python-projects
+mailing list. Information on subscription and mailing list archives can
+be accessed at
+https://lists.logilab.org/mailman/listinfo/python-projects/
+
+Your feedback is very valuable to us. Please share your experience with
+other users of the package on the mailing list.
+
+
+
+
+%package help
+Summary: Development documents and examples for logilab-constraint
+Provides: python3-logilab-constraint-doc
+%description help
+This package implements an extensible constraint satisfaction problem
+solver written in pure Python, using constraint propagation algorithms.
+The logilab.constraint module provides finite domains with arbitrary
+values, finite interval domains, and constraints which can be applied
+to variables linked to these domains.
+
+It requires python 2.6 or later to work, and is released under the GNU
+Lesser General Public License.
+
+The documentation is in the doc/ directory. Examples are in the
+examples/ directory.
+
+Discussion about constraint should take place on the python-projects
+mailing list. Information on subscription and mailing list archives can
+be accessed at
+https://lists.logilab.org/mailman/listinfo/python-projects/
+
+Your feedback is very valuable to us. Please share your experience with
+other users of the package on the mailing list.
+
+
+
+
+%prep
+%autosetup -n logilab-constraint-0.6.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-logilab-constraint -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.2-1
+- Package Spec generated