summaryrefslogtreecommitdiff
path: root/python-lotide-luna.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-lotide-luna.spec')
-rw-r--r--python-lotide-luna.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/python-lotide-luna.spec b/python-lotide-luna.spec
new file mode 100644
index 0000000..3ae17bb
--- /dev/null
+++ b/python-lotide-luna.spec
@@ -0,0 +1,95 @@
+%global _empty_manifest_terminate_build 0
+Name: python-lotide_luna
+Version: 0.7.1
+Release: 1
+Summary: Web client for lotide
+License: GNU Affero General Public License v3
+URL: https://pypi.org/project/lotide_luna/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5b/4a/cad9923d24f834c0bc5db0610d62b8b92a571531148bb310e088065ba153/lotide_luna-0.7.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-django
+Requires: python3-requests
+
+%description
+# Luna
+
+Luna is a web client for lotide.
+
+## Trivia
+
+In Latin <i>luna</i> means "moon", the celestial object that control the tide.
+
+
+%package -n python3-lotide_luna
+Summary: Web client for lotide
+Provides: python-lotide_luna
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-lotide_luna
+# Luna
+
+Luna is a web client for lotide.
+
+## Trivia
+
+In Latin <i>luna</i> means "moon", the celestial object that control the tide.
+
+
+%package help
+Summary: Development documents and examples for lotide_luna
+Provides: python3-lotide_luna-doc
+%description help
+# Luna
+
+Luna is a web client for lotide.
+
+## Trivia
+
+In Latin <i>luna</i> means "moon", the celestial object that control the tide.
+
+
+%prep
+%autosetup -n lotide_luna-0.7.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-lotide_luna -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.1-1
+- Package Spec generated